Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 · (Edited)
I have an 06 trailblazer I bought one year ago. I have put so much money into keeping her going.. Everything was going good after the last breakdown at Christmas time until 2 weeks ago... All the dash lights came on such as brakes, security, abs, check engine, one that looked like the speedometer, a wrench, and one that looks like the undercarriage. My speedometer worked but nothing else. It would start and run but not every time I tried to start it. Also when it was running, the power seats, locks, windows and blower motor do not work. We changed the ignition switch and now it won't start at all. Anyone have any suggestions before I have to spend thousands more on it?
 

·
Registered
2002 chevy trailblazer_lt
Joined
·
1,544 Posts
I have an 06 trailblazer I bought one year ago. I have put so much money into keeping her going.. Everything was going good after the last breakdown at Christmas time until 2 weeks ago... All the dash lights came on such as brakes, security, abs, check engine, one that looked like the speedometer, a wrench, and one that looks like the undercarriage. My speedometer worked but nothing else. It would start and run but not every time I tried to start it. Also when it was running, the power seats, locks, windows and blower motor do not work. We changed the ignition switch and now it won't start at all. Anyone have any suggestions before I have to spend thousands more on it?
When you were changing the ignition switch did all the circuits test out with the right voltages at the right key positions?
 
1 - 3 of 3 Posts
Top