Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner

1 - 11 of 11 Posts

·
Registered
2006 chevy trailblazer_ls
Joined
·
7 Posts
Discussion Starter #1
2006 4.2 will start then and run for about 5 to 10 sec then sputter out and die. any ideas?
 

·
Registered
2006 chevy trailblazer_lt
Joined
·
19 Posts
Any codes from the computer? I had a stalling issue on my 06 that turned out to be a PCM issue. I don't remember the code but it's on one of my posts here.
 

·
Registered
2009
Joined
·
1,088 Posts
What kind of troubleshooting have you done up until now? Any codes, is it getting fuel, is the fuel pressure constant or does it fall off. Lots of things we need to know before helping. That is probably why you haven't got any responses yet. Also, is the security light flashing? Have you changed anything lately? Do you have an aftermarket alarm system on it?
 

·
Registered
2006 chevy trailblazer_ls
Joined
·
7 Posts
Discussion Starter #5 (Edited)
no codes. no idiot lights , nothin aftermarket on it. great fuel pressure. regular maint.
I have checked cam pos sensor and actuator. i can start it over and over again but wont stay running.
 

·
Registered
2006 chevy trailblazer_ls
Joined
·
7 Posts
Discussion Starter #6
after trying to start it about 15 times in a row it finally stayed running. drove the crap out of it for about 100 miles. got home shut it off. tried to start it again and the same thing.
 

·
Registered
2006 chevy trailblazer_ls
Joined
·
38 Posts
I know this is an old thread but were you able to find out what the issue was because seems very similar to my issue.
 

·
Registered
2006 chevy trailblazer_ls
Joined
·
7 Posts
Discussion Starter #8
The mass air flow sensor was dirty. 7 dollar can of cleaner from auto zone did the trick
 
1 - 11 of 11 Posts
Top