Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner
1 - 2 of 2 Posts

·
Registered
2005 gmc envoy_sle_xl
Joined
·
3 Posts
Discussion Starter · #1 ·
Hey Guys,

whats up.. im new to the forum and i love it.. I have got alot of great info.
My 05 envoy xl just started acting up and it will literally come to a stop and just lock up.. It has done it when switching gears from 1st to 2nd... or 2nd to 3rd...

It also seeems to have done it when coming to a stop.. Its dangerous b/c I lose power steering and it just locks up and stops completely and stalls out..

There are NO error codes at all and I took it to my mechanic and he said it runs great... they tested the fuel pressure with a gauge and no issues at all with fuel pump..

I thought maybe bad gas? i dont know, so we used a lucas fuel injector cleaner...

It only does it occasionally 1 time a day or every other day... we dont drive it alot.. and when we do it slike short distances... it only has 75k miles on it..

There are no error codes and my mechanic is clueless to whats wrong with it..

I thought i would give it a shot to see if any1 has had any thing similar happen to them or any mechanics have any ideas?

could it be a short wire? pcm issue? throttle body dirty? MAF sensor?

I am doing this:

cleaning the throttle body and taking it off completely and cleaning it really good..

I wanted to also clean out and blow with elec cleaner the PCM modules. I have an 05 which looks like there is a screw or bolt that holds the pcm into place.. I have to find the right size tool to fit into the hole for the m10 bolt.. my tool set is too thick to fit it it seems... I believe i need to remove the bolt to get the pcm apart right? the bolt needs removed and that is what holds it all together right?

so i plan to clean those good and then do a reset with removing the neg battery terminal to reset the pcm...

then i was going to buy a MAF sensor but i read that the 05 envoy xls do not have a maf sensor but advanced auto said they could get me 1 for $58.99 tomo mailed in..


so I dont know what part it is? or where it is located? i read the 05 envoy xl has no maf sensor, so if thats true what are they selling me then?

on the throttle body before, i had to remove an air flow duct and there was a sensor built into that that has a clip and 2 wires, then it goes into the black housing and i slowly worked it up and out and it looks like some type of sensor or ball sensor... it goes back in then...

is that the sensor i need to spray which is my equivalent to a MAF sensor?

can i spray it with MAF or jsut use elec . cleaner.. i got stuff form crc or cnc...

anyways that is plan of attack to see if it will make it stop permanently..
when it doesnt happen the truck runs great... transitions smoothly and sounds good.. it idles perfectly right at 600 - 700rpms..

it seems like it mis fires, or I dont know it jsut locks up for no reason, when stopping or transitioning into gear.. and the entire car locks up and shuts down. I literally have to put the car in park and then restart it which it starts right up..

THERE ARE NO ERROR CODES AT ALL!!! THATS WHAT SUCKS....

I am going to try these little things, but I do not know what to do..

as for the MAF SENSOR, for the 05 envoy xl, where is it located at exactly? if we do not have them then what do we have and what is it called?

thx for your input and all your help.. this site has been a great help to me already and i love it.. keep up the great work everyone.. thx for your input if any1 can help, i am all ears...
 

·
Registered
2007 gmc envoy_denali
Joined
·
88 Posts
I had a lesabre do that to me, and a honda accord. The honda was a distributor, which was essentially the crank sensor. The lesabre.... crank sensor, lol!

But pack anything you take apart (connectors) with dielectric! will stop future problems.

As always, clean all grounds with a wire brush and apply dielectric. Also, do the same for the battery terminals! Even if they look good.... do it anyways! DON'T let a basic issue of battery intermittent connectivity bite you!
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top