Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner
1 - 5 of 5 Posts

·
Registered
2004 buick rainier
Joined
·
11 Posts
Discussion Starter · #1 ·
Hello all,
New here, just bought a 2004 Rainier yesterday. Seems the only thing on it that doesn't work is the cornering lamps on the edge of the front bumper. I think Envoys and maybe some TB's might have them to so thought I would post over here. I have tried the turn signal on with the headlights on, off, key on and off, and neither side works. The bulbs look new, but not sure if they are correct. They are double filament bulbs (3157 I think) The owners manual doesn't list the bulb numbers, nor does it mention them in the fuses..I wonder if there is a relay or controller that works them? anyone here ever have a problem with them not working?

Thanks,
John
 

·
Banned
2004 gmc
Joined
·
26,181 Posts
Envoys have them. The BCM controls the park lamp relay #30 in the rear fuse block. So if your parking lamps work, the relay's OK. Then the power goes through the F PARK fuse #37 in the rear, then the turn signal/multifunciton switch, then to the cornering lamps.
 

·
Registered
2004 buick rainier
Joined
·
11 Posts
Discussion Starter · #3 ·
Envoys have them. The BCM controls the park lamp relay #30 in the rear fuse block. So if your parking lamps work, the relay's OK. Then the power goes through the F PARK fuse #37 in the rear, then the turn signal/multifunciton switch, then to the cornering lamps.
Hi Bill,
Thanks for the reply. I don't recall if I tried just the parking lamps but I think they were on with the headlamps. So if my parking lights are working, that indicates the relay is working so I need to check fuse 37?

Thanks,
John
 

·
Banned
2004 gmc
Joined
·
26,181 Posts
Not quite. I wasn't clear. If the front parking lamps work, then the relay AND the fuse are OK, and all that's left is wiring (not likely if both lamps are out) or the lamps or the multifunction switch.
 

·
Registered
2004 buick rainier
Joined
·
11 Posts
Discussion Starter · #5 ·
Not quite. I wasn't clear. If the front parking lamps work, then the relay AND the fuse are OK, and all that's left is wiring (not likely if both lamps are out) or the lamps or the multifunction switch.
Well you gave me someplace to look and it turned out that parking lamp fuse was blown. So I guess my parking lights were not working after all..I "borrowed" the fuse for the rain sensing wipers which I don't think I have. Will stop at Auto Zone on the way home for some fuses..Hard to say why it was blown but they work now, both sides..
Thanks for the help!!

John
 
1 - 5 of 5 Posts
Top