Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner
1 - 5 of 5 Posts

· Registered
2004 gmc envoy
Joined
·
13 Posts
Discussion Starter · #1 ·
Getting codes P0651 [PCM 5-VOLT Refrence Circuit Malfunction] p0452 [Fuel tank pressure sensor circuit low input] P0651 [Again] p2135 [throttle position sensor 1-2 correlation error] P0452 [again] & P0651 [again] I've replaced; throttle body Fuel filter And am getting a fuel tank pressure sensor today because mine is missing all of a sudden. But I don't know if this is the problem for sure because I can get it running if I jump the relay for the fuel pump before starting it. But when I do get at running it goes for about 2 blocks and then the reduced engine power light comes on and it stalls out and I have to pull over and restart it and the net will drive for another 2 blocks until eventually it will stop starting altogether I have had to get it Towed back to my place and now it won't stay running longer than 1 second after starting it stalls out and sometimes it refuses to start altogether
 

· Registered
2004 gmc envoy_slt
Joined
·
2,772 Posts
Stop shotgunning parts!!!! You need to trouble shoot the source of the codes not the parts. The most likely problem is the 5VDC reference voltage that is used by all these parts. Somewhere the voltage is being either pulled down or is missing. The most common place is the fan clutch or its wire harness. Disconnect the connector at the fan clutch and see if any of the DTCs go away.
 

· Registered
2004 gmc envoy
Joined
·
13 Posts
Discussion Starter · #3 ·
Will they dissapear from the scan tool without me clearing the codes? And I also heard a little conversation about It might be the catalytic converter because a little while back I had a misfire in 1 of the cylinders and I couldn't Diagnose it because I didn't have a code reader. but I drove it like that for a long time and I heard damage to the catalytic converter could derive from that so do you think that could be the problem?
 

· Premium Member
2004 chevy trailblazer_lt
Joined
·
3,439 Posts
No, the codes will not disappear from the scan tool because they have not been erased. What will happen by disconnecting the electrical connector to the fan clutch (provided the fan clutch is the culprit) is that the engine will behave normally and the Reduced Engine Power light will go out. If you can drive for say 6 - 12 blocks successfully, then you have demonstrated that the electronic fan clutch is defective and needs to be replaced. NOW - before you go replacing the electronic fan clutch, be sure and look over the wiring going to the fan clutch to make sure that all the wires going into the electrical connector are securely seated into the connector, and look over the wires coming out of the wiring loom do not have worn insulation and are rubbing against the engine block or anything else metal and look over the wires going to the throttle body for worn insulation or being broken.

If the fan clutch is the cause, please do not replace it with an amazon/ebay $29.99 special which will likely be a chinesium white box generic special that will either likely die a way to premature death or cause lots of driveability problems. Forum favorite fan clutches are branded ACDelco/GM Genuine, NAPA Echlin, Behr/Mahle/Clevite, Dorman, or Hayden/Four Seasons. Yes, you will pay more, but you won't have to worry about them dying prematurely or causing problems.

Good Luck!
 

· Premium Member
'05 TB 4.2 EXT
Joined
·
6,192 Posts
Getting codes P0651 [PCM 5-VOLT Refrence Circuit Malfunction] p0452 [Fuel tank pressure sensor circuit low input] P0651 [Again] p2135 [throttle position sensor 1-2 correlation error] P0452 [again] & P0651 [again] I've replaced; throttle body Fuel filter And am getting a fuel tank pressure sensor today because mine is missing all of a sudden. But I don't know if this is the problem for sure because I can get it running if I jump the relay for the fuel pump before starting it. But when I do get at running it goes for about 2 blocks and then the reduced engine power light comes on and it stalls out and I have to pull over and restart it and the net will drive for another 2 blocks until eventually it will stop starting altogether I have had to get it Towed back to my place and now it won't stay running longer than 1 second after starting it stalls out and sometimes it refuses to start altogether
Dayum!
PM your address so I can open a parts store in your neighborhood.
 
1 - 5 of 5 Posts
Top