Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
4 Posts
Hello everyone,

My wifes 2004 envoy has a mystery bulb. I cannot get it to work at all. It is the lower 9005 bulb i think. I have tried all positions and it seems that the upper bulb works as the high and low beam and the lower does not function at all. Attached is an image of the bulb i cannot figure out.

http://gallery.trailvoy.com/data//545/headlight.jpg
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4
High beam

When you turn on the highbeams i am guessing the lows stay on as well? I checked at that bulb terminal for voltage and it stayed at zero the whole time even when turning on the high beams. If that is the high beam, and they are not getting any current any ideas on what may cause this? I checked the fuses and they seem to be fine.
 

·
Registered
2003 gmc envoy_slt
Joined
·
357 Posts
I'm not sure, Stalker, but maybe some other more knowledgeable folks will chime in. All I can think of is the headlight relay may not be activating the high beam. Either that or some interconnecting wiring or the multi-function switch itself not even activating the relay.

C.B.

BTW, the headlight high relay is #43 according to the owners manual.

C.B.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #8
operator error

my wife has had the car for a year... her toggling the high beams was the issue. she was using the turn switch to turn them on....... nothing was wrong once i pulled back on the turn signal....... fun. Thanks everyone.
 
1 - 8 of 8 Posts
Top