Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter · #1 ·
2003 Chevy Trailblazer LS, 4200 engine.
I put key into door lock and turn it. It acts like its attached to nothing.
Keyfob and inside door lock/unlock works just fine.

What do I need to replace to fix this? Want to have parts in hand prior
to taking inside door panel off.

-Darryl
 

·
Registered
Joined
·
2,440 Posts
I had to replace the whole lock assy in the door - and that's NOT a lot of fun!

The failure on mine was that it was worn out and it wobbled just enough to make the plastic retainer slip apart every time I used the key.

You might have the same trouble - but you've gotta get into the door panel first to find out.

Parts are cheap - especially if it's just the plastic lock-device.

56542


These (^) may not be yours, they are just an example.
 

·
Registered
Joined
·
1 Posts
On my '03 TB when i bought it, then i noticed the same thing on mine. that the key did nothing when turned in the door. i removed the door panel and noticed that the lock rod had came off of the lock cylinder and when the window was lowered then it bent the rod really badly. I took the rod off and did my best to try to reform the bends it was supposed to have. then I found a new clip and reinstalled it. now the problem is that i must not have formed the bends correctly because everytime i use the key to unlock the door now, it sets off the alarm when i open the door. but at least it will unlock the door now! Luckily i checked the key to see if it would unlock the door when i first got the TB with the door open just in case it wouldn't lol. phew, that would have sucked otherwise!
 

·
Registered
2004 Trailblazer LS 4.20 L
Joined
·
97 Posts
On my '03 TB when i bought it, then i noticed the same thing on mine. that the key did nothing when turned in the door. i removed the door panel and noticed that the lock rod had came off of the lock cylinder and when the window was lowered then it bent the rod really badly. I took the rod off and did my best to try to reform the bends it was supposed to have. then I found a new clip and reinstalled it. now the problem is that i must not have formed the bends correctly because everytime i use the key to unlock the door now, it sets off the alarm when i open the door. but at least it will unlock the door now! Luckily i checked the key to see if it would unlock the door when i first got the TB with the door open just in case it wouldn't lol. phew, that would have sucked otherwise!
the only bends in the rod should be at the ends. you may have after market security or remote start involved with that alarm situation. could be the module has a broke wire going to it or
who knows?
 

·
Registered
Joined
·
2,440 Posts
OK - it's been a couple of months - but I just ordered a new lockset from a buddy in SoCal - he's got a better price than here in Highpockets-Land.

I'll take pixs of the relay rod and see if you can match it that way. Mine was working - it's just that the lock cylinder was all worn out and it kept on falling apart.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top