Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I have a 2002 GMC envoy. This morning since we had snow last night I put the selector in A4wd and headed to work. Mind you this has been working fine all winter with no issues. Half way to work the service light came on and the selector refused to accept any other mode. After turning off ignition and restarting the selector worked fine and 4wd hi and 2wd hi function normally but when the selector is in the Afwd position after a short amount of driving it will kick the service light on again. Anyone have any thoughts on the issue? Thanks in advance.

Andrew
 

·
Registered
2004 gmc envoy_slt
Joined
·
2,444 Posts
Model year 2002 had a history of the Transfer Case Control Module (TCCM) going stupid at times. This might be your issue. Does this condition only happen when you are in A4WD, but not in 4HI? BTW, it is not advisable to use A4WD mode since it puts a strain on the front drive system and clutched in the transfer case.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
Will I need to get it reprogrammed? And BTW... where the hell is it... I am seeing conflicting info in various videos regarding driver and passenger side.
Thanks again..
 

·
Registered
2004 gmc envoy_slt
Joined
·
2,444 Posts
If you get a used one from a similar model as yours, no programming is necessary.
The TCCM is located under the dash to the left of the steering column.
 
1 - 5 of 5 Posts
Top