Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I have an oldsmobile bravada 99 and the AC is not working. I have checked and charged it. It seems that the compressor pully is spining, but the outter part is not. Is this normal?
 

·
Northwest Chapter
Joined
·
11,824 Posts
Welcome to the site man!

Unfortunately you have a completely different truck than what everyone on here does, you have a S10 platform Bravada (90s-00) and not a GMT360 platform Bravada (02-04). You have a 4.3L V6, the GMT360 has the 4.2L I6. About the only shared parts are the transmission between these trucks.

Id recommend searching and then posting on www.s10forum.com for a better chance of getting an answer. Good luck getting your answer!
 

·
Registered
2003 chevy trailblazer_lt_ext
Joined
·
8,770 Posts
Sounds like your clutch isn't engaging. Check the fuses. Sometimes, when the correct recharging gas isn't used, the compressor won't engage because it isn't being oiled properly. It will stay off to protect itself from getting damaged
 

·
Registered
2005 chevy trailblazer_ls
Joined
·
1,733 Posts
You haven't charged it if the clutch don't come alive. Sometimes the kits you get at auto-zone and the like don't want to take. I have tried before with these and failed to get it to take. I put my 30 lb can and robinair gauges on it and no problem. BUT sometimes it is just a bad compressor. These for your truck are reasonably priced tho. it is 134a right?
 
1 - 5 of 5 Posts
Top