Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner

1 - 2 of 2 Posts

·
Registered
2006 gmc envoy_denali
Joined
·
2 Posts
Discussion Starter · #1 ·
I have a 2006 Envoy Denali with about 55K. Got it about 6 months ago. So far the problems I have had with have been simple things like the air springs need replacing and the oil pressure sensor. Well last night I had a quick errand to run and I got maybe 2 miles down the road and the check engine light came on then it just died. Called a buddy to come tow me who live about 15 mins away but by the time he got there it started up and i was able to aleast drive it home. Ran my code reader and got P1516, P2101, P0443, P689, and P1682. I replaced the battery and ignition switch today thought i fixed it because it ran for awhile but then the same thing happened. I have no idea where to go from here and trying not to bring to a mechanic unless i have to. I have some knowledge of working on vehicles but when it comes to all the computer stuff im at a loss
 

·
Registered
Joined
·
1 Posts
my 006envoy denali is throwing the same codes. Did you ever get yours fixed? If so what was wrong with it?
I have a 2006 Envoy Denali with about 55K. Got it about 6 months ago. So far the problems I have had with have been simple things like the air springs need replacing and the oil pressure sensor. Well last night I had a quick errand to run and I got maybe 2 miles down the road and the check engine light came on then it just died. Called a buddy to come tow me who live about 15 mins away but by the time he got there it started up and i was able to aleast drive it home. Ran my code reader and got P1516, P2101, P0443, P689, and P1682. I replaced the battery and ignition switch today thought i fixed it because it ran for awhile but then the same thing happened. I have no idea where to go from here and trying not to bring to a mechanic unless i have to. I have some knowledge of working on vehicles but when it comes to all the computer stuff im at a loss
 
1 - 2 of 2 Posts
Top