Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner
1 - 5 of 5 Posts

·
Registered
2005 chevy trailblazer_lt_ext
Joined
·
2 Posts
Discussion Starter · #1 ·
I have a 05 Trailblazer, I6, 4X4, EXTLS and it has some rough running issues. I originally had a PO306 code come up so I replaced the following in this order:

1. spark plugs- still running rough
2. coil pack on #5 & #6- still running rough
3. replaced #6 injector, intake gasket, valve cover gasket, camshaft sensor, crankshaft sensor and the orings on all the injectors. Now the stupid thing runs even rougher and throws a PO300 code. I checked the intake for leaking by removing the vortec plastic and covered the T.B and the motor died. So now Im scrathing my head as to why this thing is running worse after I replaced all those parts? Im about to lite it on fire and burn it to the ground.:duh: What are the intake torque specs for the intake manifold? I called several Chevy dealers and every one of their service techs said they dont know! Really? How are you a service tech and not be able to get the torque specs?:crackup:
 

·
Registered
2002 gmc envoy_slt
Joined
·
3,203 Posts
Check that the wiring harness to the injectors and coils haven't been pulled a part or damaged. The PO300 is random misfires across multiple cylinders. Since you've had the packs and plugs out, you may have one or more coils that aren't tightly snapped onto their plugs or damaged the wiring harness.....that would be my first thought.

Where did the new plugs and which ones? - For some reason, most non AC-Delco plugs do not work well in the I6, the only ones guaranteed to work consistently are the ACD 41-103. (If you bought just about anything else, return them for the ACD part number.....some have found NGK Iridiums work well, most other platinum/copper don't is misfire).

Some of the aftermarket coils can be bad out of the box, several members have had issues with non AC-Delco coils. There are also TWO coil designs, the older, more rounded design and a newer more square/taller unit. - You can ONLY use the newer ones with the new silver/metal valve cover and the original with the black/composite valve cover, they're not interchangeable....just a heads up, if you picked up the opposite coils.
 

·
Registered
2002 gmc envoy_slt
Joined
·
73 Posts
If you disconnected the battery then you should also clean your throttle body. Disconnect the negative battery cable and leave it off for 30 minutes while you clean the TB. That won't cure the misfire but it could contribute to a rough idle problem.
 
1 - 5 of 5 Posts
Top