Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner
1 - 13 of 13 Posts

·
Registered
2005 chevy trailblazer_lt
Joined
·
4 Posts
Discussion Starter · #1 ·
Ok...im going to short story this...tried to star my truck...all lights bells and whistles worm but nothing with the key when tryjng to start. Checked battery connectiins and voltage, checked ALL fuses, check starter voltage, checked ignition switch...voltage in and out , replaced starter relay. So, in addition when i try and start the car and lock symbol come on...no blinking just stays lit. Never goes off unless key is removed. I have read that you can bypass or trick the system into thinking the "correct" key is in the ignition but no real directions..HELP!!!!!
 

·
Registered
2002 gmc envoy_slt
Joined
·
3,203 Posts
Have you tried the passlock relearn procedure?

30 Minute Learn Procedure
Tools Required: None
1.Turn ON the ignition, with the engine OFF.
2.Attempt to start the engine, then release the key to ON (vehicle will not start).
3.Observe the SECURITY telltale, after approximately 10 minutes the telltale will turn OFF.
4.Turn OFF the ignition, and wait 5 seconds .
5.Repeat steps 1 through 4, 2 more times for a total of 3 cycles/30 minutes. The vehicle is now ready to relearn the Passlock Sensor Data Code and/or passwords on the next ignition switch transition from OFF to CRANK. IMPORTANT: The vehicle learns the Passlock Sensor Data Code and/or password on the next ignition switch transition from OFF to CRANK. You must turn the ignition OFF before attempting to start the vehicle.
6.Start the engine. The vehicle has now learned the Passlock Sensor Data Code and/or password.
7.With a scan tool, clear any DTCs if needed. History DTCs will self clear after 100 ignition cycles.
 

·
Registered
2005 chevy trailblazer_lt
Joined
·
4 Posts
Discussion Starter · #5 ·
Unfortunatly yes I did...I only got the flashing security after I replaced the ignition housing and ignition switch. No go...grrrrr...now the light just stays on along with the battery light and cruise control light...i am so confused...i have checked all connections, grounds etc....
 

·
Registered
2004 chevy trailblazer_ls
Joined
·
4 Posts
Same here!

I got my security light stuck on my 2003 trailblazer. bought a tech 2 reading B2945 code when I try to start . when I clear the clode the light turns off, but when I go to start it again it pops back on, still no crank. Did you ever have luck with this?
 

·
Registered
Joined
·
29 Posts
Have you guys tried jumping the starter relay terminals to make it crank when it security mode. I don't know if the system is sophisticated (hope not) enough to kill fuel pump or injector pulse. But it will crank if you jump the 30 and 87 term on the relay.
 

·
Registered
Joined
·
2 Posts
I think I might be having the same issue with my 05 TB!
I had to disconnect my battery to reset a code ("camshaft position sensor - too advanced" whatever tf that means) and my dumbass self locked the doors after popping the hood, and closed the door (hence arming the alarm)
Well, it started going off as soon as I started to disconnect to battery; I quickly unlocked the door and attempted to disarm it, truck wouldn't fully start; but big woop, she has issues with that sometimes and it's the next issue to tackle, but the alarm stopped.
Well after I'm done with the battery being disconnected and reconnect everything, she won't even attempt to start! Power locks and windows won't work, no door chime with key in and driver door open, inside lights won't come in with driver door open but will for the rest, no radio AT ALL, just my dash display and head lights, and if I leave it on "ON" the only lights on my dash are check engine, battery, abs, brake, and airbag, no security light... I've checked every fuse and they all look golden, but I'm unsure how to check the relays... Did I fry my truck?!?
 

·
Registered
Joined
·
1 Posts
I think I might be having the same issue with my 05 TB!
I had to disconnect my battery to reset a code ("camshaft position sensor - too advanced" whatever tf that means) and my dumbass self locked the doors after popping the hood, and closed the door (hence arming the alarm)
Well, it started going off as soon as I started to disconnect to battery; I quickly unlocked the door and attempted to disarm it, truck wouldn't fully start; but big woop, she has issues with that sometimes and it's the next issue to tackle, but the alarm stopped.
Well after I'm done with the battery being disconnected and reconnect everything, she won't even attempt to start! Power locks and windows won't work, no door chime with key in and driver door open, inside lights won't come in with driver door open but will for the rest, no radio AT ALL, just my dash display and head lights, and if I leave it on "ON" the only lights on my dash are check engine, battery, abs, brake, and airbag, no security light... I've checked every fuse and they all look golden, but I'm unsure how to check the relays... Did I fry my truck?!?
You ever figure out what the problem was? I’ve got the same year truck and the same camshaft code. Same problem with my lights on the dash working but no radio.
 

·
Premium Member
'05 Chevy TB EXT
Joined
·
5,138 Posts
NEVER DISCONNECT THE BATTERY.

One more time for emphasis ---> NEVER DISCONNECT THE BATTERY!

Did you ever think that the cam really is too advanced and it's reporting the truth?
 

·
Registered
Joined
·
1 Posts
Ive got the same issue with my 03 trailblazer.Theres a 10 or 11 wire connector behind the lower left knee panel. theres a metal comb connecting the wires together. Unplug it the next time it wont start and then start your car. this worked for me awhile. Im ready to take it to a dealer now as that will no longer for me.
 
1 - 13 of 13 Posts
Top