Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I've been having a knocking sound on startup the last few days. I have a suspicion it's either the fan clutch or the water pump, probably both at this point. I took a video of the Running engine, the fan looks really loose and you can hear a bit of knocking. I also took a look at the Water pump and noticed it has some play in it. About a month ago I also got a CEL code P0495, but replacing the fan relay fixed it. Is it time to replace them? Thanks for the input
 

·
Registered
2004 chevy trailblazer_ls_ext
Joined
·
288 Posts
I would guess the water pump is about to leave the building, just like Elvis. I suspect the play in the pump is causing the loose fan. It shouldn't rock like that. If you're going to replace the pump and have any doubts about the fan clutch, then it just makes sense to do them both at the same time. I wouldn't go cheap on these parts, either. My philosophy is that if a part is tough to replace, or is safety critical, go OEM. For consumables, go aftermarket. But that's just me. Your mileage may vary.
 

·
Registered
2004 chevy trailblazer_lt
Joined
·
956 Posts
AMEN to what flyboy2610 wrote about the water pump getting ready to take let loose.

As to the parts t use, again, do not cheap out. Go with ACDelco OEM parts or parts from a company that has been around for a long time and has a reputation to protect. When I did my water pump and fan clutch I went with the top of the line NAPA parts (parts have a lifetime warranty) and they have been going strong.

You will also likely notice a reduction in engine compartment noise as well.
 

·
Registered
2002 Pewter ls with automatic trans. 4x2, gray cloth interior.
Joined
·
70 Posts
I've been having a knocking sound on startup the last few days. I have a suspicion it's either the fan clutch or the water pump, probably both at this point. I took a video of the Running engine, the fan looks really loose and you can hear a bit of knocking. I also took a look at the Water pump and noticed it has some play in it. About a month ago I also got a CEL code P0495, but replacing the fan relay fixed it. Is it time to replace them? Thanks for the input
Holy cow that's a wobbly fan! I would start with the pump and I seen the Delco selling for under $100 on amazon.
 
1 - 4 of 4 Posts
Top