Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I’ve had this problem for more than a few months now when i go to start my 05 TB sometimes the abs, brake light, battery, and airbag light will turn on and the car won’t start and when those lights are on the radio doesn’t turn on, windows don’t roll down, and doors don’t lock. simply disconnecting the battery will reset it and the car will start but sometimes just the radio won’t turn on aswell and disconnecting the battery and reconnecting it will do the trick. please help i’m tired of dealing with this as it’s been really cold out and i’m tired of disconnecting the battery to get my car started, from all the forums i’ve read i think it’s a bad gauge cluster but i want others input before i spend the money to get a new one and not fix the problem
 

·
Registered
Joined
·
122 Posts
I’ve had this problem for more than a few months now when i go to start my 05 TB sometimes the abs, brake light, battery, and airbag light will turn on and the car won’t start and when those lights are on the radio doesn’t turn on, windows don’t roll down, and doors don’t lock. simply disconnecting the battery will reset it and the car will start but sometimes just the radio won’t turn on aswell and disconnecting the battery and reconnecting it will do the trick. please help i’m tired of dealing with this as it’s been really cold out and i’m tired of disconnecting the battery to get my car started, from all the forums i’ve read i think it’s a bad gauge cluster but i want others input before i spend the money to get a new one and not fix the problem
My truck starts without the cluster attached.
 
1 - 2 of 2 Posts
Top