Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner

1 - 3 of 3 Posts

·
Registered
2005 chevy trailblazer_ls_ext
Joined
·
2 Posts
Discussion Starter · #1 ·
Hello all, first time poster here. Been reading it for awhile but just recently signed up.

To the problem. My 05 Trailblazer has begun to cut out while idling and it feels like it might be stuttering while cruising but its hard to tell.

I now have about100,500 miles on the car and it been cutting out for about 500 miles or so. (400 just this weekend). I recently had the car in the shop to replace the a/c module and blower. Then a couple weeks after, the cutting out started. One VERY important thing to note is I let the gas tank get to empty before filling up. I filled up, then a day later the problem started. So I ran some lucas cleaner through it and once I got down to around a 1/4 tank it seemed to clear up. Well I then ran the car to empty again. (Fuel milage is horrible right now for some reason. Only 12-13mpg in town) But it started chugging again and I've not been able to get it to quit. I took it to my mechanic he said drive it out. Since there are no codes he can't do much. That was 400 miles ago and the car actually died at a light yesterday.

I replaced my plugs after the first round of chugging started. That was when it cleared up. I thought a few of the 6 plugs had some oil on them too, the were damp. I showed them to my mechanic too, and he wasn't worried. I have read that the cat convertor could be causing issues and not throwing CE codes. Is that still a good thought at this point and is there something I can do on my own to check?

So here I am looking for any other help before I take the car in and start getting nailed with charges.

Thank you very much in advance for any info that you guys might have.


Yancy
 

·
Banned
2007 chevy trailblazer_ls
Joined
·
237 Posts
Did you used AC delcos iriduim sparkplugs? Are trucks dont like anything else and will run like crap if you dont use those plugs. Also, you should clean your throttle body. Theres a great how to. Search this in the search bar. "Throttle body cleaning" Im sure that will solve your problems. Good luck.
 

·
Registered
2005 chevy trailblazer_ls_ext
Joined
·
2 Posts
Discussion Starter · #3 ·
Thank you for the quick reply.

I cleaned the throttle body when I changed the plugs and I'm pretty sure I used the Iridium plugs.
 
1 - 3 of 3 Posts
Top