Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner

1 - 4 of 4 Posts

·
Registered
2004 chevy trailblazer_ls_ext
Joined
·
24 Posts
Discussion Starter #1
I have an 04 trailblazer with the 4.2l, giving me absolute fits. For some reason, it randomly stalls at stop lights when the A/c or heat is all the way on. it usually acts like a slow stall, the RPMs drop way low, then quits, but then it starts right back up after i put it in neutral or park.
I have checked the Alternator, and sprayed for vacuum leaks, done plugs and coil packs, but i am not quite sure where to go from here. it is not throwing a check engine light so my computer wont help any...

Any help would be awesome.
 

·
Registered
2008 isuzu ascender
Joined
·
977 Posts
Pull the throttle body off and thoroughly clean "both" sides of the throttle plate . Reset the pcm by pulling the fuses for 30 minutes .
 

·
Registered
2004 chevy trailblazer_ls_ext
Joined
·
24 Posts
Discussion Starter #3
Pull the throttle body off and thoroughly clean "both" sides of the throttle plate . Reset the pcm by pulling the fuses for 30 minutes .
so i did that as part of the spark plugs and coil packs thinking that it was standard procedure. should i do it again?
 

·
Registered
2004 chevy trailblazer_ls
Joined
·
105 Posts
I've had the same issue for as long as I've had mine (approx 3 yrs 30K miles. it has 181K on it now) when a/c or defrost is on ... heat is ok. My solution (unfortunately) is to turn off the ac/defrost while I'm stopped. Crude, and a nuisance, but it works.:rolleyes:
 
1 - 4 of 4 Posts
Top