Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner

1 - 13 of 13 Posts

·
Registered
2004 chevy trailblazer_ls_ext
Joined
·
148 Posts
Discussion Starter #1
I just replaced the blower motor resistor in my '04 TB LS. Easy job, took about 20 minutes start to finish. The new resistor sure doesn't look like the old one, which has a date of 08-01-04, so I'm sure it was original. It worked for nearly 16 years, so I guess that's not bad. I replaced it with an AC/Delco part because I really don't like using 3rd party electrical parts, unless they are from a good solid brand name company. No Dorman electrical's for me, thanks! The new resistor mounts 180 degrees opposite the original, but there is a plastic post built onto the blower motor housing that prevents it from being installed in OEM orientation. Turn it 180 degrees and it fits just perfectly. A PO put a big rubber band around the blower motor itself and that is how they were fastening the blower motor wires in place. The clip was intact. I still need to get back in there, because it was when I was going to plug the resistor connector back in that I realized I was out of dielectric grease. As Eeyore would say: "Oh, Pooh."
Anyway, I thought I'd show you a pic of the old resistor. Talk about bare-bones!
001.JPG


The reason for replacement is because I lost fan speeds 1-3 all at the same time. I've got them all, now, though! Look like someone took a sandblaster to the old one! :eek:
 

·
Registered
Joined
·
634 Posts
Yup. What you have there is an old resistor.

How did it fail? HIGH blower die or some lower speed?

If HIGH speed, I have a permanent higher capacity and much easier upgrade for you for next time.
 

·
Registered
2004 chevy trailblazer_ls_ext
Joined
·
148 Posts
Discussion Starter #3
It lost speeds 1,2, and 3 all at the same time. It was working when i went to work at 6:30 AM, came out at 3:30 PM, and only 4 and 5 worked. I had a real good idea it was the resistor, and I think I got the only AC-Delco unit in Lincoln! Took about 20 minutes to change, and all 5 speeds are working again! Happy day! :D
 

·
Registered
Chevy Trailblazer 2008 LTZ (4.2L)
Joined
·
178 Posts
Not so long ago we repaired this resistor, we were helped by replacing the microcircuit .....1405P
QBNP1575.jpg
 

·
Registered
Joined
·
634 Posts
I don't recognize that item.... where is this circuit?
 

·
Registered
2004 chevy trailblazer_ls_ext
Joined
·
148 Posts
Discussion Starter #6
I don't think the heater blower motor resistor has a micro-circuit. The heat would cook it in no time. Of course, I've never torn one apart to find out.
 

·
Registered
Joined
·
634 Posts
I have taken them apart and they are nothing but a bank of printed resistors with miniature heat sinks on them and lots of trace squiggles to dissipate heat ... IDK!

Unless four resistors and some squiggly traces constitute a module ... just calling it that seems sacrilegious for electronics engineers.

The biggest RIP off is the secret fuse that's printed on the board, but covered up by the base of the "module" when it's all glued together. It's not readily visible but it's also hard to access even when you know where it is.

Judicious use of an Xacto knife and a Dremel got me to the print-o-resistor in 10 minutes or so.

I tried to repair the resistor by soldering a jumper from end to end on it. All it did was shrinking the traces from a 20Watt soldering pen and it was a total loss after 3 or 4 attempts. It was futile to try to repair that link or jumper it out. I think the traces (circuts) are antimony or bismuth... something with a really low melting point.

Thinking in retrospect, it might have been easier to drill it out and just use small bolts to create a jumper with some copper wire, two crimp ended spades and a 30 amp fuse.

Next time? Maybe.... but I have a fantastic repair ... which up to now is still a secre.

MY repair is for when you lose ANY SPEED and need to purchase a new "module" <irk, irk> ... and my purpose is to take the High Amps load off that fuse and thus can save it from overheating and burning out.

I've made this mod dozens of times and AFAIK .... they are still working today.
 

·
Registered
Joined
·
634 Posts
PS ---> it's still a secret.

But I can be bought.....
 

·
Registered
Chevy Trailblazer 2008 LTZ (4.2L)
Joined
·
178 Posts
Guys, I made repairs as written in this thread. And it helped me. I was having problems losing fan speed.
From myself, I can add only a few photos. (2008 automatic climate control)
TVEQ1957.JPG


VCMZ8662.JPG


WNEU5026.JPG
 

·
Registered
2004 gmc envoy_slt
Joined
·
2,414 Posts
The manual (slider) and automatic (digital display) HVAC systems use two different blower motor control modules. The manual one uses a resistor pack module and the auto uses an electronic module.
 

·
Registered
Chevy Trailblazer 2008 LTZ (4.2L)
Joined
·
178 Posts
Therefore, I clarified in my message that I was repairing an automatic control module.
 

·
Registered
2004 gmc envoy_slt
Joined
·
2,414 Posts
The most common failure on the auto HVAC blower control module is the Power FET, as can be seen it is discolored in Vega's pictures.
 

·
Registered
Joined
·
634 Posts
The most common failure on the auto HVAC blower control module is the Power FET, as can be seen it is discolored in Vega's pictures.
Given decent soldering talents, is the FET replaceable? Is there any code or parity identifiers that need to be added?
 
1 - 13 of 13 Posts
Top