Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner
1 - 12 of 12 Posts

·
Registered
2004 chevy trailblazer_lt
Joined
·
6 Posts
Discussion Starter · #1 · (Edited)
i got an alpine ida-x001 the other day w/ a gmos-04 harness for my '04 Chevy trailbalzer...i have all the wiring diagrams, im a beginner and having trouble figuring out how to install both the harness that came w/ the alpine and the gmos-04, basically need to know what wires im supposed to splice from the alpine harness and the gmos harness to the factory harnesses...do i actually splice into the gmos w/ the alpine harness or just the factory harness? no bose or onstar in the truck... any help would be APPRECIATED !! THANX!
 

·
Banned
2007 chevy trailblazer_ss_1ss
Joined
·
2,006 Posts
why do you have the GMOS-04 harness for if you dont have BOSE or Onstar?? The GMOS-01 is the one for non BOSE but w/Onstar.. you probably could've found a cheaper harness... unless you got that one for free.. good luck.. a lot of extra wires going on their..
 

·
Registered
2004 chevy trailblazer_lt
Joined
·
6 Posts
Discussion Starter · #3 · (Edited)
didnt see a big price differential b/w the 2 harnesses....got the gmos-04 off ebay for $35 bux, finally think i hooked everything up but the headunit isnt responding...doesnt power on or anything...theres gotta be a writeup out there somewhere for this harness...a simple one would help me figure out what im missin...is that really my prob, using a gmos-04 instead of a gmos-01...?
 

·
Banned
2007 chevy trailblazer_ss_1ss
Joined
·
2,006 Posts
didnt see a big price differential b/w the 2 harnesses....got the gmos-04 off ebay for $35 bux, finally think i hooked everything up but the headunit isnt responding...doesnt power on or anything...?
either or will work.. you'll just have some extra wires with them.. the GMOS also keeps your RAP's (retain accessories power) and all warning chimes...so when the TB is turned off you still have power until the door opens like from the factory.. good find on that harness tho.. i seen them go for easily $99+ at regular car audio shops...
 

·
Registered
2004 chevy trailblazer_lt
Joined
·
6 Posts
Discussion Starter · #5 ·
if i got this straight u splice the headunit (alpine) wires into the gmos-04 and the gmos-04 is used to bypass the factory harness..? still missin something i guess cause the headunit wont power on
 

·
Registered
2005 chevy trailblazer_ls
Joined
·
371 Posts
Start with the inline fuse on the power wire going to the HU and then the one on the HU.

The red wire from your HU should go to the red wire on the GMOS. Once you plug the GMOS to the factory plug, it gives you the ignition signal. I would then start verifying your ground wires.

If that doesn't work, hook your red and yellow wires from the HU to the yellow wire of the GMOS to verify that the GMOS is good.
 

·
Registered
2004 chevy trailblazer_lt
Joined
·
6 Posts
Discussion Starter · #7 ·
pardon my ignorance! the ignition signal? what exactly is that? and if i hook the red and yellow from the HU to the yellow from the gmos and it still doesnt work i can safely assume its just a defective gmos...?
 

·
Banned
2007 chevy trailblazer_ss_1ss
Joined
·
2,006 Posts
pardon my ignorance! the ignition signal? what exactly is that? and if i hook the red and yellow from the HU to the yellow from the gmos and it still doesnt work i can safely assume its just a defective gmos...?
+12V power sourse.. like when you turn the truck on.. its a "switch" so you can't turn the radio on when the truck is off etc... it only powers up when the truck is on...

and i dont know about the red and yellow wire.. i never experienced with that.. the only time i have seen that is for the same reason but the kid left it that way so he was never able to have memory in the radio. it always reset when he turned his car off.
 

·
Registered
2005 chevy trailblazer_ls
Joined
·
371 Posts
The yellow wire is your constant 12v power wire. This wire retains the radio's memory. By hooking the red (ignition turn on wire) and the yellow wires to the yellow wire from the GMOS unit, you can find out if the GMOS isn't providing the ignition source like it should. So, with the red and yellow hooked up, you should be able to turn on the radio with-out turning the key to the "on" position.

If this works, you know your radio is good. I would then hook the red wire from the GMOS to the red wire from your radio and turn the key to "on". If the radio doesn't power up, the GMOS could be bad. I would double check all of the connections going to the GMOS before buyng another one...incase something was overlooked.
 

·
Registered
2004 chevy trailblazer_lt
Joined
·
6 Posts
Discussion Starter · #10 · (Edited)
well crap...i musta blown a fuse or something cause i hooked the factory HU back up and i get no power on that either now...i did cut a few wires on the factory harness but i spliced them all back together...? how do u get to the radio fuse under the 2nd row seat and is there anything else i can check besides the fuse?
 

·
Banned
2007 chevy trailblazer_ss_1ss
Joined
·
2,006 Posts
well crap...i musta blown a fuse or something cause i hooked the factory HU back up and i get no power on that either now...i did cut a few wires on the factory harness but i spliced them all back together...?
not to be mean or anything man..just my :m2: but it sounds like your in over your head...why would cut wires on the factory harness to begin with???:confused:

but either way good luck, maybe its just time to chalk it up and take it to audio installation shop...
 

·
Registered
2004 chevy trailblazer_lt
Joined
·
6 Posts
Discussion Starter · #12 ·
:)lol, not over my head...gotta cut the speaker wires on the factory harness for install anyways....it was just a blown radio fuse, replaced the fuse and now the unit worx perfect thanx fellas 4 the help ! :)
 
1 - 12 of 12 Posts
Top