Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner
1 - 11 of 11 Posts

·
Registered
2004 chevy trailblazer_ls
Joined
·
4 Posts
Discussion Starter · #1 ·
Couple of days ago my wife was pulling out of a parking lot and it just died. Since then, we've had intermittent problems getting it to start (but hasn't died while driving since then). As of this morning, I can't get it to start at all. Two different things seem to happen randomly.

1. Turn the key, all power looks fine (lights are fine, radio, windows, etc). It cranks but the engine won't start.

2. Sometimes, as soon as we turn the key to accessories (before even trying to start), all the guages and lights on the dash flicker and eventually power to the dash cuts out. If we try to start when it's like this, we get nothing.

We had the battery and alternator checked the day it started happening and they are both fine (I tried with a fresh battery from another vehicle today anyway just to rule it out).

The only other thing to note, we had the instrument cluster replaced a couple of weeks ago (tachometer and speedometer weren't working).

I've done a little bit of searching other posts and it sounds like it might be the ignition switch, but I didn't see any posts that really describe the symptoms of that problem so before I throw time and money at that, I figured I'd ask.

Car is out of warranty so trying to go as far as I can myself. When dash has power the service engine light is not lit. I don't know how to pull the codes on the TB (not sure if you can without a reader, I can on my other car).

Suggestions?

Thanks,
Matt
 

·
Registered
2009 chevy
Joined
·
6,431 Posts
My 1st thought was fuel pump, until I read the dash problems.

You might be right about the ignition switch.
 

·
Banned
2004 gmc
Joined
·
26,181 Posts
Totally convinced it's the ignition switch. Cheap do it yourself replacement.

The starter relay would prevent starting, but its failure couldn't stop a running vehicle.
 

·
Registered
2004 chevy trailblazer_ls
Joined
·
4 Posts
Discussion Starter · #5 · (Edited)
Totally convinced it's the ignition switch. Cheap do it yourself replacement.
I see two different version in the GM parts catalog, one "with gear teeth" and one "with plunger". Any idea which one I need for an 04 LS TB? Do you know the part number?

And just to make sure, we're talking about the ignition switch, not the ignition module, right? The switch looks to be about $20?

And if anyone has a link to the replacement instructions, please post it. I'm searching around now but haven't found it yet!
 

·
Registered
2004 chevy trailblazer_ls
Joined
·
4 Posts
Discussion Starter · #8 ·
yeah it did kill mine while I was going down my driveway :undecided:undecided
So I'll try that first, it's less work :). Is there another relay with the same specs that I can just swap in to see if it fixes it before buying one?
 

·
Registered
Joined
·
8,781 Posts
So I'll try that first, it's less work :). Is there another relay with the same specs that I can just swap in to see if it fixes it before buying one?

no there is only one of its kind under the hood.. I picked a new one up at autozone for 9 bucks
 
1 - 11 of 11 Posts
Top