Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner
1 - 5 of 5 Posts

·
Registered
2004 chevy trailblazer_ls
Joined
·
49 Posts
Discussion Starter · #1 ·
I have changed the plugs....fuel filter....air filter...Cleaned the throttle body...put seafoam in thru the brake booster vac...tectron and still have the rough idle!

Any other ideas!
 

·
Registered
2005 chevy trailblazer_ls_ext
Joined
·
2,667 Posts
There are other threads running with this same question. You might want to use the search function.

Also it would help to know which engine you have - I6 or V8? Please fill out your user profile.

BTW - Have you done a compression check on the engine, or had the PCM updated?
 

·
Registered
2004 chevy trailblazer_ls
Joined
·
49 Posts
Discussion Starter · #3 ·
Rough Idle on TB V6

I had the codes read today and had a misfire on cylinder #5 so I switched the coil pack to cylinder #4 and reread the code and #4 was misfiring so I ordered another coilpack. Will know tomorrow if it solves the rough idle. If not then I will get a compression test. The PCM update what is that all about...?
 

·
Registered
2005 chevy trailblazer_ls_ext
Joined
·
2,667 Posts
There is an update for the 04 PCM. I'll have to research it because I don't remember what all it was about since I don't have an 04.
IIRC there were some fixes for engine performance problems.
 

·
Registered
2004 chevy trailblazer_ls
Joined
·
49 Posts
Discussion Starter · #5 ·
TB running LIKE NEW AGAIN! (rough idle)

Hey! Well after cleaning the throttle body...fuel filter...plugs...cleaning injectors with seafoam..airfilter...and MAP sensors I narrowed my rough Idle and Acceloration down to one bad coil pack! Replaced it and CEL is off and TB is running like NEW!

Again thanks to Trailvoy and all its members I was able to solve my problem!

Terry

Trailblaizer with a vortec 6 4200
 
1 - 5 of 5 Posts
Top