Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I've got a grind under the front end and I checked the wheel bearings and those where ruled out. But when I push on the front shafts they move up and down in and out but not even 1/8in either direction any idea what maybe the cause
 

·
Registered
Joined
·
311 Posts
CV joints have never made a grinding sound in all my years experience. Grinding is typically a rotational noise - bad bearings, bad front differential carrier bearings - something like that. But you said you've had that all inspected - so it still has to be in the front end - in a rotating area.

CV axles moving up and down is not too bad at 1/8" - but really they should not move much - if any - at all. But I don't believe they are a noise maker.

They CAN wobble if they are worn out - but that'd be at road speed.

BTW: Is this 'In-n-out' motion the inner shaft or the outer axle end where there's supposed to be a very tight nut and cotter pin? If there's up-n-down motion where that axle nut is - you've got a serious problem.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
It's a up and down motion by the diff. If I get on the throttle pretty good the grinding stops until I let off. Another thing I forgot to mention in the original post is it didn't do it until i changed the passenger side rotor and pads. But the rotor appears to be fine
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
So after thinking about doing the brakes on the passenger side and looked up part numbers on the rotor the rotor autozone gave me was for a 08 not a 04. The 08 rotors are 20mm wider thin a 04 and .3 mill shorter on the hub so I'll be swapping it out and seeing if the issue is fixed
 

·
Registered
Joined
·
311 Posts
So after thinking about doing the brakes on the passenger side and looked up part numbers on the rotor the rotor autozone gave me was for a 08 not a 04. The 08 rotors are 20mm wider thin a 04 and .3 mill shorter on the hub so I'll be swapping it out and seeing if the issue is fixed
Good catch!
 

·
Registered
Joined
·
4 Posts
Discussion Starter #7
I found this nois on the driver side after changing the rotors back to the 04 it's on the shaft going into the diff but I cant upload a video of it
 
1 - 7 of 7 Posts
Top