Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner
1 - 2 of 2 Posts

· Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hi Everyone. Just joined your community, and hope I can help others and find help for myself as well. That's what it's all about, Right?

This is my first Trail Blazer, bought it for my wife. I've had a couple unresolved issues with it that I have to deal with, but my current one is... I drove the truck the other day, all was fine. She took it to the store, worked fine. We went to go to dinner, and nothing. No start, no crank, but had lights and lighting, and accessories worked. Turned out to be the ignition switch. I put one in this morning, and now everything works fine again, except, now my "Security" light is on constant. How do I make that go away? Owners manual says it's on because the ignition was tampered with.... I guess ripping it out by the roots and replacing it constitutes "Tampering". I could always jerk the cluster and fill the bulb cavity with Black Silicone, then I'll never see it again, but I figure I better try the correct way first. Anyone able to help me out here? Thanx in advance for any help you can give me. Thanx, Rick
 

· Registered
2004 chevy trailblazer_lt
Joined
·
1,373 Posts
The problem is with the passlock system. If the system was triggered an event or the switch doesn't support passlock, it will have this happen. If the former is the issue, try disconnecting the battery for an hour and see what happens. If it is the latter, get a ign switch that has been known to work and replace it there. This procedure should not be causing the passlock system to freak. Get the system checked and read, but it sounds like passlock is disabled...
 
1 - 2 of 2 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top