Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
The previous owner replaced the battery just before I purchased it, we assumed it was an actuator but I (pain stakingly) removed the drivers side actuator, and hooked it up to the passenger side cable and it works like a charm, but when I hook it up to the drivers cable it acts as if it’s frozen up, any suggestions?
note: i switched it back and forth to make sure it wasn’t working in the drivers side, and one of the times I hooked it up, it turned all the way to the cold side, then turned all the way back to the hot side and acts like it’s froze up again, my dad took it apart and all the gears look just fine.

doubt this is relevant but the motor blower resistor is also going out.
 

·
Registered
2002 chevy trailblazer_lt
Joined
·
1,224 Posts
One caution,,, if an actuator is opened up, be certain to NOT remove any gears or turn anything unless you already know how to reassemble keeping the indexing potentiometer in exactly the right place with reference to the final drive.

And although the actuators all look the same and will bolt in the same, they are NOT the same for all positions AND some are different between years. A couple are interchangeable but it is best to double check part numbers not only when replacing but also to perhaps verify that a previous owner didn't put in an incorrect part.

Ten years ago when I first had my 2002 TrailBlazer LT I noted the air was considerably colder on the passenger side. Upon investigating I found the charge was low. Corrected that and it was good to go.
 

·
Registered
Joined
·
1,628 Posts
|| Ten years ago when I first had my 2002 TrailBlazer LT I noted the air was considerably colder on the passenger side. Upon investigating I found the charge was low. Corrected that and it was good to go. ||

The evaporator is on the passenger's side - that accounts for some of the colder air on that side.

Heating core's there too -
 

·
Registered
2003 Envoy SLT AWD 4X4
Joined
·
15 Posts
Could be the blend door actuator...alot of times when disconnecting battery the plastic gears on the actuatora sometime break off when reconnecting....is there any clicking noise in your dash when key is turned over? If so its definitely actuator
 
1 - 4 of 4 Posts
Top