Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner

wont start

  1. Audio and Electronics
    I’ve had this problem for more than a few months now when i go to start my 05 TB sometimes the abs, brake light, battery, and airbag light will turn on and the car won’t start and when those lights are on the radio doesn’t turn on, windows don’t roll down, and doors don’t lock. simply...
  2. Audio and Electronics
    I own a 2004 Envoy SLT. I went out to put something in the car and noticed the car would not unlock. I opened the door with the key and hooked up the car to a battery charger, we noticed the battery was charging really slow. Once the battery was charged, I attempted to start the car with no...
  3. 2013+ Chevrolet Trailblazer Forum
    hey guys i have a 06 envoy I6. my wife was in town the other day .after shopping she went to fire it up and no start. i went in the next day to try and figure it out ,but it fired right up. so i drove 40 miles back home with no problems an shut it down for the night got in it the next day and it...
  4. General
    Ok so I have searched and searched and can come up with similar threads but not close enough to my problem. I have a 2006 TB 4.2l with 130,000 ish miles. I have never had any issues at all electrically. Today I was driving and the radio, oil, temp, fuel, and amp gauges and windows and locks...
  5. OEM Issues
    2005 Isuzu Ascender 4.2L V-6 I recently started having issues with my truck starting. I have previously had some issues that appear to be electrical so I'm not sure if this is just another symptom of a bigger electrical problem or not. I was leaving work and the truck wouldn't start. When I...
  6. OEM Issues
    Drove from TN to IL yesterday, woke up this morning drove and got coffee everything fine. Went out again, started my TB, it started fine ran rough for a few seconds died and I have been trying all day to start no SES light on or anything. I leave in a couple days, please help!!:bonk:
  7. General
    :bonk:I tuned up my TB this past weekend 165,000 miles on it. I drove from TN to Illinois yesterday and it did fine, even got about 24 MPG. Ran great, no trrouble what so ever. I got up this morning, started right up. I went back in the hotel, came out to start it to go somewhere, it started...
  8. General
    :bonk:I tuned up my TB this past weekend 165,000 miles on it. I drove from TN to Illinois yesterday and it did fine, even got about 24 MPG. Ran great, no trrouble what so ever. I got up this morning, started right up. I went back in the hotel, came out to start it to go somewhere, it started...
  9. General
    hello. i am having an issue with my voy not starting with the key. i have an aftermarket remote start and it still starts the voy perfectly. all accesories work when started with the remote. however when i use the key to start the envoy, nothing happens. it doesnt crank, the guages dont move...
  10. General
    I have an 02 Envoy and need some help. I am 2 hours from home and it will not start. All lights work, battery meter reads 14 and is only 6 months old. When I attempt to start it i get a breif "rrr" and then nothing. Tried to jump start it and still does the same thing. For now i simply need...
Top