Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner

water pump

  1. Cooling Fan rattle and P0495 code: related?

    The 02-09 "How-To" and DIY Section
    I've got a 2006 TB (4.2, V6, 4WD) with 218200 on it. She's old. Recently got a rebuild transmission installed, and just did the starter myself yesterday. Now, the next project... On a recent move from CO to CA I noticed two things. First the code (P0495) was thrown as I was climbing up I-70...
  2. Large/Fast Coolant Leak - after replacing thermostat and water pump

    OEM Issues
    I recently expietenced a cooling system failure on my way back to work on lunch break. My engine temp spiked and my engine alarms started going off. Luckily I was really close to my work. I was able to get it to the parking lot, opened up the hood and coolant was spraying/leaking everywhere. It...
  3. New water pump and metal shaving particals inside engine

    General
    New water pump and metal shaving particles inside engine Hey everyone, i have 06 TB 4.2L 2wd. At 167K I found out that my oem waterpump has gone bad and decided to replace it, which i did. All went well until i started to hear grinding noise. Decide to look it up. Least i know i thought it was...
  4. [SOLVED] YES, Solved! rough idle, horrible noise on hard acceleration

    The 02-09 "How-To" and DIY Section
    Just a little post to let some folks know that a nasty rough idle and noisy acceleration (especially 1-2 upshift) in my 2004 Trailblazer was actually caused by a faulty water pump!!?!. I never lost any anti-freeze, but could always smell it, I only noticed a rough bouncy idle, not RPM's...
  5. Ball joint and waterpump replacement, how many hours is fair?

    Suspension
    Hi, I brought my truck in for upper and lower ball joints, water pump and thermostat. The mechanic quoted me 4 hours. The owner charged me over 11!! and marked up the parts 60% on top of it. He will not honour what his mechanic told me. But before I go to BBB to complain, I want to see what...
  6. 03 Trailblazer running hot after thermostat change

    OEM Issues
    My 03 has about 90 thousand miles on it. The other day I was driving and the check engine light came on. I hooked up my scanner to it and it was giving the code for the thermostat. I changed the thermostat in it and now it went from running too cold to running way over 210 but not in the red...
  7. Front end noise after major coolant leak and replacing water pump

    General
    Hello Folks, I had to replace the water pump on my 02 Trailblazer. I got everything back together, and I had the classic dirty throttle body symptoms after having the battery disconnected - it would almost stall, rpms around 300 after turning on A/C or defrost. So I removed and cleaned the...
  8. Coolant flush fail

    General
    I found a puddle of coolant in the driveway the other day. Thought it was tranny fluid at first but then noticed the level of the overflow reservoir was low. When I went to drain the coolant it looked as if the leak had come from the lower radiator hose. So I drained the fluid and replaced...
  9. Quality Water Pump

    OEM Issues
    All, I have a 2005 trailblazer (4.2 V6) for which I have changed the water pump 2 times since owning it. As the pump begins to go bad the idle in the car gets rougher and rougher. When I replace the pump it cures the problem until the bearings start to go. I have been replacing it with a $30...
  10. Found the issue with my car!

    General
    So I found out what the noise was that was coming from my car today. It's worse than I thought, and I have a video that shows the issue. From what I see, it's the water pump. When the engine is on, the pump moves and when it does it makes the noise I hear. I'm happy I know what the issue is...
  11. Replaced water pump

    OEM Issues
    Hey guys new to the forum i have a big problem i replaced the water pump in my 2006 trailblazer LS 4.2 V6 and now the fan clutch wont turn on at all and the car keeps overheating i dont know what i did wrong and i need to fix a.s.a.p if any of you can give me some advice or thoughts i need it...
  12. [SOLVED] Replaced fan clutch and thermostat, still clicks

    The "How-To" and DIY Section
    Sorry guys but I have another "fan clutch" thread. I was hearing a clicking sound on my 03 trailblazer (100K miles) that disappeared when I disconnected the link to the fan clutch. From what I have been reading, that is a classic sign that it is about to go. Then I started getting engine...
  13. MY WATER Broke!! Replaced water pump now have SES and Reduced Power

    OEM Issues
    OK what started off to be a somewhat of a normal problem now has transformed into yet another problem. Murphy's Law comes knocking yet again at my house!!:hopeless A while back I noticed a somewhat fast coolant leak:worried:. All systems still running "belt was moving with fan". Then on the way...
  14. It's DIY Repair Time again; Water Pump, CV Boots, Pinion Seal, Sway Bar Links

    OEM Issues
    My favorite time of year... Well recently had some noise coming from the fan clutch / water pump area and took it to a dealership to get their opinion and they state it is the water pump that needs replaced. However, I just replaced both about 2 years ago so I thought it was odd. Anyway, here...
  15. It died! I killed it! 4.2 heaven! Fan Clutch - Water Pump - P0304 - P0300- Engine!

    OEM Issues
    Well this is a long drawn out story that is worth writing and I thought I'd take a few minutes to share some experiences worth hearing about. All started a week ago, I was towing my RV back from Indiana and the TB started overheating, Check engine light was on and it turned out to be a bad fan...
  16. 25/F/car-dumb HELP!!

    OEM Issues
    I would like to apoligize if this post needs to go some where differnt, I am new to this whole thread and online thing. Used to just being able to call upon family but I have moved and have no one here to help me!! :( I have self diagnosed :woot: my 2004 GMC Envoy 6 cly. to have a bad water...
  17. Replaced water pump, now won't start

    OEM Issues
    Thanks to all the great help on this forum, I replaced my water pump with minimal problems yesterday. But, now my TB won't start. I managed to jump it off twice, but only if I pumped the gas pedal a little bit, I haven't been able to do that since though. The battery is only a year old, and I...
  18. Diagnosis: fan clutch?

    OEM Issues
    '04 Envoy 4.2 65k mi. For the past couple of months, I have been getting the erratic tick from the front of the motor. I did some research on this site and found the infamous fan clutch as the likely culprit. The truck ran fine, no problems. Last week, the "check gauges" light comes on and...
Top