Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner

transmission problems

  1. [SOLVED] P0756 Shift Solenoid B Wont go away - Need Help

    The 02-09 "How-To" and DIY Section
    NOT Solved: P0756 Shift Solenoid B Wont go away - Need Help I just bought a 2004 I6 2WD with 150k miles. The truck had sat for an extended period due to engine missing on 4-5-6. Towed it home and did the tune up: drained gas tank, cleaned throttle body, new plugs, fuel filter, coil pack for #4...
  2. no 1st gear

    Transmission Mods
    I just bought a 04 trailblazer 4X4 with almost 200,000 miles. All other gears are working fine,just no 1st gear. I just replaced the 2 shift solenoids so i know that is not the problem. When I did replace the solenoids 1 of the popped off on its own, the other did not. I had to pry it off. I...
  3. 02 TB Transmission issues help

    Transmission Mods
    I have a 2002 Chevy Trailblazer LTZ SWB 4.2 I6 4WD that i bought March 2016 with 211,XXX miles. The transmission was rebuilt 1 time that I am aware of before purchase(approx 27,000 miles before I bought it). The transmission failed in less than 3k miles after purchase. It was replaced with a...
  4. Replaced Tranny - Now I have problems

    General
    02' TB LT 4x4, 171,000 mi. Just replaced a broke tranny with a used one...I know not the smartest move, but save the comments. The tranny was inspected and is functioning mechanically. The issues are as follows: Speedometer now reads ZERO all the time - worked fine before swap. Tranny won't...
  5. Transmission overheating?

    OEM Issues
    I have a 2006 6-cylinder Trailblazer, 4WD, 125,000 miles. I have a 30 mile daily commute, on the expressway running about 70-75 MPH. Lately, every day at the same point in the commute, the RPMs suddenly shoot from around 2400 to over 3,000. I can hear/feel a difference. I have to back down...
  6. [SOLVED] Stuck in 1st gear til @>35Mph

    OEM Issues
    I have 04 Trailblazer EXT 4.2L VIN S 8TH DIGIT, that i did an engine swap after blowing the original. :sadcry: The engine was from an 03 but everything went fine and the truck drove fine for over 2 month (at least 400). i started having a problem with it not shifting gears without the engine RPM...
  7. Trans in "limp" mode

    OEM Issues
    I went to a local trans shop and they ran the codes for me, shift solenoid a&b, torque convertor solenoid, as well as a couple others (5 codes total). The guy at the shop said it sounds to him that the trans isn't getting any power. I have checked most of my fuses and they all seem in perfect...
  8. Remanufactured Transmission

    Transmission Mods
    Known issues: Seal leaks, shuddering between shifts, higher rpm rev till shift 2003, 4.2L V6, 151k The leak has been very small and very slow for about two years. This is my wife's daily driver, grocery getter and kid hauler. The mechanic who changes her oil and does all her maint told her...
  9. Transmission slipping.

    General
    I have a 03 tb ls. Im having transmission problems, when i go to take off from a stop and feather the gas its fine but if i give it to much gas the transmission slips and then bangs into gear. Also driving at 55 or 60 mph when just maintaining speed the transmission keeps jerking the suv, seems...
  10. went from slipped to skipped!

    AWD Drivetrain
    brand new to the forum!... 08' stock everything w/ 96K miles I would smash the pedal to the medal on the highway (just under 80mph) and very rarely would it try to shift into 1st and over rev. (happened maybe 3 times) well it did it again except now im having problems! 2nd gear itself started...
  11. Rear end collision possible tranny probs

    General
    Hello guys, I have a 2003 GMC Envoy, 4 wheel drive. I was recently rear ended while i was in gear waiting to change lanes. I just got my vehicle back last week 10/5. Saturday(10/8) I was driving on the highway and my SUV started driving hard and the automatic gear would not shift for the...
  12. New Transmission but NO GEARS

    4x4 Drivetrain
    I have an '03 Trailblazer EXT 4x4 with ~85,000k. Just replaced the transmission with a used unit. Replaced all tranny and transfer case fluids to proper levels, including fluid in the torque converter. With the help of two Master Mechanics, I finished up the job late last night. Started the...
  13. Does not go into any gear, but starts up fine

    General
    2002 GMC Envoy with 159k. Starting it up has no problem and engine runs. Push on the gas and it revs up. Putting it in ANY gear and it just does not move. For a while there was a clicking noise under the vehicle, which i thought was the transmission. It started to die out on the freeway...
  14. transmission shifting hard from 1st to 2nd gear

    Introductions
    hello, this is my first post and still comfused about my trans. i will shift hard from 1st to 2nd. it gets better as it warms up. i seen alot of things on here but nothing that i can find that will fix this issue. i took it to a trans. shop and they drove it and said there wasnt any thing...
  15. no reverse and forward neutral

    TrailBlazer / Envoy Chat
    -------------------------------------------------------------------------------- hey guys so here is my intro i am a new father as of march 8th 2011 to a babygirl and am very happy to bring her home in my trailblazer 4l60e. but apperantly i was a lil to happy a few days ago. one morning at the...
  16. Major transmission problem - can someone help?

    Transmission Mods
    this is my first post, but ive been a lurker on this site for years and want to thank all of you for the info in the past. now im in some need of advice before i go jump off a cliff.. I have a 2wd 02 trailblazer Ls 4.2 w/ 4l60e trans. about 4 months ago my tranny went out @ 175,000. it started...
  17. Tranny makes whining noise when cold and when put into drive or reverse.

    Transmission Mods
    I have a 2004 Trailblazer 155K every morning when I start it, a whining noise comes from underneath the vehicle it goes away after 2 to 4 seconds after I star the engine, I have checked the fluids and they are all ok. When I put it into drive it also makes the same whining noise as well as in...
  18. Trailblazer 2002 Transmission slipping at high speed

    General
    Hi, I need your help badly. I have taken the car to various mechanics and they can't find a problem, nothing comes up on the computer. The problem is that when I am driving at over 50 MPH and I lightly step on the gas pedal, the car hesitates/transmission slips/doesn't engage. This problem...
Top