Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner

shifting

  1. 04 envoy shifting issues

    02-09 General Tech Q&A
    I have an 04 gmc envoy xl that is having issues shifting out of first gear. When i first start the car and drive it, it will jump into second gear and the whole car seems to jolt forward. This only happens a couple times and then it will shift fine, however it seems the rpm might be high when it...
  2. Shifting Issue

    OEM Issues
    I have a 2005 Trailblazer LS 4.2L motor. I was having any issue with shifting out of 2nd gear so the truck would not get above 40MPH, it was just rev up when it was time to change to 3rd gear. The check engine light was on so I pulled the codes and it came back that I needed a speed sensor. I...
  3. Speedo, Shift Indicator, ABS Light, Etc

    OEM Issues
    Short-time reader, first-time questioner here. I recently got an 05 LT EXT for a song, but there are a few quirks that I need to clear up before I trust that it's road worthy. First I'll start with the things that I believe are connected. Both brake warning lights are on and the speedometer...
  4. Transmission slipping and losing gears

    4x4 Drivetrain
    Recently my 2003 Trailblazer (4.2 V6) transmission lost power while driving on the freeway. I decided to do a full tune up on the vehicle in hopes that it would fix the problem. I changed the transmission fluid and filter and replaced the spark plugs. For two days, my car was running like a...
  5. [SOLVED] Stuck in 1st gear til @>35Mph

    OEM Issues
    I have 04 Trailblazer EXT 4.2L VIN S 8TH DIGIT, that i did an engine swap after blowing the original. :sadcry: The engine was from an 03 but everything went fine and the truck drove fine for over 2 month (at least 400). i started having a problem with it not shifting gears without the engine RPM...
  6. HELP - Loss of Power and Shifting Problems (No Engine Light)

    OEM Issues
    Hi all, I'm new to the forum and hoping someone can help me... PLEASE!!. I have a 2003 Envoy with the l6 and we are having major issues. It has a major loss of power at full throttle or under heavy acceleration. Normal driving is fine but when I mash the pedal to WOT it may or may not go into...
  7. 04 Trailblazer 4.2L sluggish, irregular shifting

    General
    Hey guys, I need some expert opinions on what has proven to be a hard issue to resolve. I bought a 2004 Trailblazer 4.2L about 2 months ago. About a week or so after I owned it, it started to seem quite sluggish to me, and it also shifted hard, especially in the lower gears. Then the check...
  8. Trans Shifting Problem???

    Transmission Mods
    I ahve a 2006 Envoy Denali V8. When it is driven for more than 5 miles or when it gets up to interstate speeds it seems to shift hard from 1st to 2nd. If I just drive it around town then it has no problem. I have been to the transmission shop and they said it wasnt the transmission so Im...
  9. Major transmission problem - can someone help?

    Transmission Mods
    this is my first post, but ive been a lurker on this site for years and want to thank all of you for the info in the past. now im in some need of advice before i go jump off a cliff.. I have a 2wd 02 trailblazer Ls 4.2 w/ 4l60e trans. about 4 months ago my tranny went out @ 175,000. it started...
  10. Battery Impact on Engine Performance

    General
    I took my 04 TB into the shop because the battery would go dead if not driven for a couple of days. Prior to this, I was experiencing some performance issues (rough idle, lower fuel mileage, shifting at higher RPM in low gears, etc). I think the battery might have had a bad cell (brand new 6...
  11. "Boost" while shifting from 1st to 2nd

    Transmission Mods
    Question about a transmission issue. My '03 Ascender has 123k miles. Just recently the truck gets a little "boost" while shifting from 1st to 2nd. This only happens if I accelerate slowly or quickly. If I do a real smooth acceleration, the little boost is not felt. Thanks for the help. JT
Top