Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner

sensor

  1. wheel speed sensor cap screw, pentagon bit really?

    General
    Trying to do a front wheel speed sensor fix as my 2009 has the ABS engaging at slow speeds while stopping. I checked and there is plenty of rust on the hub. Pretty sure this thread describes my fix forums.trailvoy.com/showthread.php?t=94580 So I jack up the front end, remove the tire...
  2. Air Ride - Runs then immediately releases air ?

    General
    Hey guys, My 07 Denali will cycle the compressor at startup, but then after it runs it then shortly after starts letting air out. When I hear the very faint sound of it releasing pressure it will stop as soon as I push down on the bumper. So the valve is working properly. Why is it letting...
  3. ABS Sensor question

    General
    My ABS is kicking in at low speed stops and I've been going over some forums and found that alot of people have had this problem after doing maintenance to the hubs or they had bad hubs I have neither. What I do have is a leaking rack and pinion fluid coming out of the boot, could a build up of...
  4. early or late model 05

    General
    I have a 05 Envoy and I am a newbie when it comes to cars. How do I find out if I have a late or early model. I need to find out if I have the maf of map sensor I have seen on here 05 model changed between the two(early or late).
  5. 2002 Envoy - Can only describe as "wheezing"

    OEM Issues
    I have an '02 Envoy that has been giving me fits. A little history, a few years ago it started doing what I would call wheezing. Under acceleration, instead of a low smooth rumble, the engine would sound like it was under a much higher load (RPM's normal) louder and more of a high-pitched...
  6. Automatic headlight sensor problem?

    General
    Hey guys, I'm new to the site and have a 2009 trailblazer. My low beam headlights in auto mode are always on, with the car in gear, even when it the sensor on the dash is in broad daylight. So, I have just been switching the lights completely off in the daytime, but I want to know why the...
  7. Trans Shifting Problem???

    Transmission Mods
    I ahve a 2006 Envoy Denali V8. When it is driven for more than 5 miles or when it gets up to interstate speeds it seems to shift hard from 1st to 2nd. If I just drive it around town then it has no problem. I have been to the transmission shop and they said it wasnt the transmission so Im...
  8. Camshaft Position Sensor

    OEM Issues
    I replaced my camshaft position sensor a couple of days ago (Very easy to do) But after i did it my SES light is still on and my cruise doesnt work now. The truck doesnt stall anymore (Thank God) and is running great but i am still having these two problems. I got a 6 1/2 trip coming up and i...
  9. only passenger side a/c works and RPMs are jumping around

    General
    I just had my fan clutch replaced this morning because it went bad. As I left the shop I kicked on the A/C and rolled up the windows. I immediately saw the RPm gauge jump to almost 0 RPM's, then it went back up to normal. I sat there for a bit and it continued to do this till I shut off the A/c...
  10. Automatic Headlights always on

    Exterior
    Hello All - I've searched for a few hours to try and fix this issue, but didn't see anything. I have an 06 Envoy and the low beams are always on when the switch is in 'auto' position. I've tried switching 45 and 46 relays...no change. All other functions of the switch work properly (lights...
  11. New york o2 problem

    OEM Issues
    Alright, I own a 2004 Chevy trailblazer 4x4 4200 I6. I had a clogged cat and instead of dropping the 600+ on replacing it I straight piped it. Now that dang CEL keeps coming on :hissy: Now i replaced the O2 sensor as a precautionary for further problems and used the nonfouler set up to keep the...
  12. Knocking noise at 70mph

    Engine Tunes/Mods
    A month ago Ive got headers install which was great btw, everything seemed fine except getting the engine code P0420 which was the high flow cats. I got it removed from the tune but the light still pops out. But that's not the problem. A month later Im starting to hear knocking noise for the...
  13. 04 TB Running Rough - Crank/Cam Sensors

    Engine Tunes/Mods
    Greetings: I have an 2004 TB. The other day it started running really rough and "sputtering", especially in park while it's idling. The SES light was on but the only code was regarding the thermostat (stuck open). I was waiting to do this until it warms up a bit as I live in Michigan and...
  14. Expert opinions (sensor readings)

    OEM Issues
    Opinions (sensor readings) I'm wondering if someone can give me a little info on these readings. I saw on another thread with results similar to mine at idle(they were said to be OK), but I want to know about the readings taken while driving. I'm getting 9 MPG (mostly around town):cry: and have...
  15. Tuning Rochester NY O2 problem

    Engine Tunes/Mods
    I have a 2004 Trailblazer 4.2L I6 and was wondering if anyone had a tuner or know where I can get the truck tuned. I have been having problems with my O2 sensor throwing a code. I have 110000 miles on the truck and recently put a new catalytic converter and o2 sensor in the truck. Everything was...
  16. Help...I can't get my oxygen sensor off.

    General
    I'm trying to replace the front o2 sensor on the Envoy. The socket just slips and will not loosen it...any ideas how to get it off?
  17. Codes...aren't they supposed to be in Games?

    General
    -------------------------------------------------------------------------------- I replaced my ECT (electronic coolant Sensor) after reading my code that it was bad. Two weeks later the engine light came back on and read the same Code.... I checked my other sensor plugs and added electrical...
Top