Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner

rough

  1. OEM Issues
    I've bought an 05 Trailbalzer with the I6 in it knowing it had a few issues. i've fixed all the suspension issues and am now on the last leg of the engine. Currently it has a rough idle (i suspect a bad motor mount) to include starting the engine and shutting it off it just kinda clunks to a...
  2. OEM Issues
    Ok, so I just got a 2005 Envoy 4.2L wth 140,000 miles on it. It had a rough idle so I cleaned the throttle body and it helped a bit. This morning the check meter light came on and i noticed that my oil pressure was going from half to a quarter back and forth. It was running pretty darn rough...
  3. The "How-To" and DIY Section
    I have researched it up, and I've found several accounts of what it could be. The most common that seems to be popping up is the throttle body is dirty needs to be cleaned. But there is another one with a coil? I have attempted to research how to fix that, but I cannot find anything about it...
  4. OEM Issues
    Hi everybody! This is my first post, so I hope I threw this in the right place. So I know there are already plenty of threads regarding this sort of thing... I changed my spark plugs, I used AC Delco 41-103 plugs, I made sure they were all gapped around .042, I used dielectric grease, I made...
  5. General
    I need your all help :hail::hail: I purchased my TB since one month with 93000KM , the engine working perfectly but as a routine maintenance I decided to make by myself and as I learnt from this valuable site I did a clean of my TB and changed the spark plugs and air filter During the...
  6. OEM Issues
    As the subject says, yet another rough idle question... Vehicle: 05' TB I6 w/102K miles Problem: Intermittent rough idle. RPMs drop from 600 down to 400, then back up. Seems like TB is going to stall, but has to actually do so. Doesn't seem to matter if AC is on or off. CEL is NOT on (and...
  7. General
    I am having a problem with misfiring that I can not pinpoint. When the vehicle is first started the engine runs fine. However after it warms up a little the engine misfires when I come to a stoplight and it also misfires when I am cruising on the highway at around 2100 rpm. I have a code...
  8. OEM Issues
    I have searched around a bit and have yet to come across a solution(s).... We have an 03 Envoy XL 4.2...The idle has been rough so I did a basic tune up replacing all of the filters, fluids, and spark plugs. Still the rough idle persisted. The check engine light came on so I took it to the...
  9. Engine Tunes/Mods
    Greetings: I have an 2004 TB. The other day it started running really rough and "sputtering", especially in park while it's idling. The SES light was on but the only code was regarding the thermostat (stuck open). I was waiting to do this until it warms up a bit as I live in Michigan and...
  10. OEM Issues
    I have an 04 Trailblazer (46K miles). It was great before I was t-boned in September. The body work took 2 months to complete and looks great. Unfortunately, when I picked it up, it idled rough/vibrated, especially when cold and between 6 and 700 rpm. I was hit on the passenger side and it...
Top