Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner

not working

  1. General
    Hello, I'm sorry if this has already been asked, but after some searching I can't find any threads that match. I just bought an 04 TB EXT LT 6cyl and it came with 1 key and 1 fob, so I went and bought 2 more keys and they work great. But I also bought another fob and it programmed to the car...
  2. OEM Issues
    Hello Everyone, I'm searched through the forums for an answer to my question, and Roadie seemed to be onto one but I want to explain my specific problem before I attempt to fix the issue. A couple days ago I had an iSimple installed into my vehicle. After it was installed everything worked...
  3. General
    Just found out last night, that my headlights are not working. I'm going to inspect it now and see if I can figure out why.. I don't feel as if its 2 bulbs out, seems like more of an electrical issue. I have the auto lights, but also when I tried to manually turn them on, they don't. However...
  4. OEM Issues
    My gas gauge does not light up as bright as all the other gauges in the cluster. I have done a search and found that it is the bulbs behind the overlay but did not see any info on what type of bulb or were to purchase them. Anyone else that has done this repair please help me find the bulbs...
  5. 4x4 Drivetrain
    I have a 06 tb and haven't needed to use the 4wd until this winter. Pulled out onto my street back tires spinning with a4wd. I had to creep really slow to get going. Switched it into 4hi, same thing. Came to a stop, put it in 4low and I felt and heard it engage, so i know 4low works. I haven't...
  6. 4x4 Drivetrain
    It seems like my little TB has the flu! Alot of strange symptoms lately. Other than the security light coming on and off by itself and the 4x4 selector light either not on or blinking then going off. (sometimes they stay on an work fine) but wth the recent snow in chicago I went and put it in...
Top