Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner

misfire

  1. Ignition coil problem.

    2013+ Chevrolet Trailblazer Forum
    2003 Trailblazer lt 4.2, cylinder 3 started misfiring a couple weeks ago and I determined the ignition coil for that cylinder went bad by first unplugging #3 coil and noting there was no difference in how rough the engine was running then unplugging #2 to note how much rougher it ran with two...
  2. Help With Coil On Plug Trouble Shooting 05 Trailblazer 4.2

    The 02-09 "How-To" and DIY Section
    So my 05 Trailblazer began running rough a couple days ago.It was slightly choppy sounding with a misfire also.I bought a scanner and pulled codes earlier tonight.Two map sensor codes were present,but Im almost 100% sure they're from 3 months ago when I had Autozone pull codes which lead me too...
  3. 2004 4.2 Envoy Random misfire and no power

    Engine Tunes/Mods
    I have a 2004 envoy with the 4.2 I replaced the plugs and coil packs 6 months ago and it has run perfect. I went to start it up las week and it ran like crap. I put my code reader on it and got codes for the cam position sensor and the vvt actuator solenoid. I replaced both. Now I onlt get the...
  4. Misfire Cylinder #2

    OEM Issues
    Hello everyone, I'm new here, but I've used this site to troubleshoot a bunch of problems on my Trailblazer. I have a 05 Trailblazer LT The truck has about 160K and the engine has about 95K. I keep getting a misfire on the second cylinder and can't get rid of the code. The truck will run...
  5. someone help! p1345 and random misfires

    The 02-09 "How-To" and DIY Section
    so im working on an 03 tb with the 4.2, and this thing has got me stumped. very rough idle, stalls, no power, will not accelerate at all. pulled codes, got p1345 along with a random and a cyl3 misfire. changed plugs, pulled out acdelcos, unknown if they were original or not, but #3 was...
  6. '04 Misfire/ECM Codes

    OEM Issues
    Greetings, my '04 TB started running rough while just driving down the highway. The SES light is blinking under acceleration but steady when going down hill. Have had three coils fail on this truck in the past three years or so, each time producing the same symptoms. So off I go to AutoZone to...
  7. '04 Misfire/ECM Codes

    The "How-To" and DIY Section
    Greetings, my '04 TB started running rough while just driving down the highway. The SES light is blinking under acceleration but steady when going down hill. Have had three coils fail on this truck in the past three years or so, each time producing the same symptoms. So off I go to AutoZone to...
  8. Dreaded flashing engine light

    OEM Issues
    Hi everyone, Before I get to my problem here is a little background info on the vehicle. It is a 2006 Trailblazer 4.2 LT2 with 200,000 miles. I have owned the vehicle for 9 years and up until recently I have never had a problem. I stayed up to date on all regular and recommended maintenance. No...
  9. Continuing Misfire Problems- What's Next?

    OEM Issues
    Hey Everyone, I'm new here and have an issue I'd like to get some better insight on. I have a 2004 Envoy, I6 with a continuing misfire P0300 issue. 150,000+ miles. Several weeks ago, the engine started to misfire (blinking check engine light, running terribly). I put in AC Delco plugs about...
  10. Changing misfire code - 0305 then 0301 on '03 EXT LT 4.2

    OEM Issues
    Hi everybody, I need some help asap. My battery went out last January in a remote place and I had Walmart replace it. The genius over-tightened the positive terminal and it loosened over time(stripped threads) allowing corrosion to set in. A couple days ago, the terminal finally went...
  11. '06 5.3L misfire questions

    General
    I have been sitting on this problem for a while now and reading horror stories about the lifter/AFM/replacement engine costs so I finally decided to start investigating the problem to see what I could find. My engine is only misfiring on cylinder 4 so I have changed the plug (have the others to...
  12. p0306 missfire

    OEM Issues
    I changed my plugs a short while ago due to a very bad misfire on cylinder #6. the new AC Delco plugs fixed the rough idle and misfire....for about 3 weeks. I was sitting in a drive-thru when the miss returned. now after another 3 weeks today it finally set a CE light, I pulled the code when I...
  13. compression too high? cyl 3

    OEM Issues
    I have a 2002 trailblazer with 138000 miles. Been having the infamous misfire issues for a couple months now. Did all the usual suggestions, cleaned throttle body, changed plugs, replaced 1 coil pack, cleaned camshaft position sensor, changed oil, seafoamed, put in fuel injector cleaner, using...
  14. [SOLVED] Completely stumped

    General
    I recently purchased a 2002 trailblazer, vortec 4.2L I6 LS 2WD. I have noticed that when you are sitting at a stop, and then quickly switch back to gas and begin to accelerate it seems to lose power for a second and then take off. this was the first issue I found until I was driving in town...
  15. P0300 - Can't track the misfire down

    General
    Well it seems I have the dreaded P0300 misfire and I'm having a terrible time tracking it down. I'm in a bit of a tight situation right now and can't throw money at it to see if coils will fix it so I'm hoping to find a few hints and help here. It's a 2004 4.2L 2wd. The back story is that I...
  16. Intermittant P0394 Misfire code

    OEM Issues
    So I have a 2007 TB with about 113k miles, it has the I6 engine. I am very familiar with these engines as in the past I already have had an Envoy for many years and put over 175k miles on it. A few months a ago I started to get the cylinder 4 misfire code and I read about every forum on here...
  17. [SOLVED] Rough idle after spark plug change

    OEM Issues
    Hi everybody! This is my first post, so I hope I threw this in the right place. So I know there are already plenty of threads regarding this sort of thing... I changed my spark plugs, I used AC Delco 41-103 plugs, I made sure they were all gapped around .042, I used dielectric grease, I made...
  18. Thank you Trailvoy.com

    OEM Issues
    Thanks again to Trailvoy.com for helping me diagnose a problem and get it fixed cheap. I had a rough idle and went to parts store to have code scanned, Cylinder #4 misfire. I bought a new coil and 6 spark plugs. With this forum and pics on someone's posting I was able to change out the coil...
  19. [SOLVED] *** urgent please help ***

    OEM Issues
    Hi. I have a 2004 gmc envoy with CAI and highflow exhaust, The envoy has just started to mis-fire extremely bad, its not in limp-mode but misfires badly on acceleration and every 5-9 seconds at idle. engine even shakes a little. I've tried seafoam treatment and nothing. I think I can hear a...
  20. P0410 and Misfire ?!?

    OEM Issues
    First - Thanks to everyone on the site - HUGE valuable source of information on my '04 TB Second - About 10 months ago started getting sporadic P0410 codes usually only when it was raining (I've read TONS about this problem) Eventually the code stayed on all the time. :worried: Discovered...
Top