Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner

idle

  1. Oil Pressure Drops at Idle when Hot

    General
    My 2005 GMC Envoy has 171,000+ miles on it. After running for about 15min or so, when I'm at idle at a redlight my oil pressure drops, but if I put it in neutral and rev the engine it goes back up. I checked the oil level while warm and it was good. Most of my parts are in good shape as I've...
  2. 2003 Envoy High Idle (1,000 RMPS)

    General
    Hey guys this is my first post so please bear with me. I have a 2003 envoy SLT 4x4 and randomly it will start idling high at around 1,000 RMPS. Before when this happened it gave a code (dont remember what the code was) and the guy that scanned the code at advance auto parts said it was the...
  3. Rough Idle/Poor Gas Mileage

    OEM Issues
    I've bought an 05 Trailbalzer with the I6 in it knowing it had a few issues. i've fixed all the suspension issues and am now on the last leg of the engine. Currently it has a rough idle (i suspect a bad motor mount) to include starting the engine and shutting it off it just kinda clunks to a...
  4. Running out of options.. weird idle and loss of power

    OEM Issues
    Hey there, I have been putting some serious blood, sweat, and tears, (and money ), yet I am still having the same or similar issues happening. Recent repairs: Fan clutch and water pump installed Tension pulley replaced. camshaft position sensor replaced. both oxygen sensors cleaned Throttle...
  5. Rough Idle(Not Throttlebody)

    OEM Issues
    Ok, so I just got a 2005 Envoy 4.2L wth 140,000 miles on it. It had a rough idle so I cleaned the throttle body and it helped a bit. This morning the check meter light came on and i noticed that my oil pressure was going from half to a quarter back and forth. It was running pretty darn rough...
  6. AC, idle, and airbag problems

    General
    Hello everyone! I'm new here and if this is too many problems or I am posting wrong please let me know. I know nothing about cars, just so you know. But I am learning. I have very few tools handy. I have someone who has everything I would need though. I have a 2004 TB 4×4 1. I just replaced...
  7. Intermittent stall at idle.

    OEM Issues
    My wife's 2004, 4.2L, 223,000 mile, TB intermittently stalls at stops. When it stalls, she says it's as though she's turned the key off. There's no stumbling or roughness, it just stops running. It restarts instantly with no roughness. No DTCs (trouble codes) stored. This vehicle otherwise runs...
  8. Please Help vibration at stop while in drive

    General
    Hi I'm John and new to the site please forgive me if I have posted in the wrong area but I need help bad and have posted in other areas with no help please anyone that may know what I need to do please let me know thank you in advanced and GREAT site I have done/learned allot from here. I'm...
  9. [SOLVED] 03 Trailblazer Engine Light Flash

    The "How-To" and DIY Section
    I have researched it up, and I've found several accounts of what it could be. The most common that seems to be popping up is the throttle body is dirty needs to be cleaned. But there is another one with a coil? I have attempted to research how to fix that, but I cannot find anything about it...
  10. Intermittant P0394 Misfire code

    OEM Issues
    So I have a 2007 TB with about 113k miles, it has the I6 engine. I am very familiar with these engines as in the past I already have had an Envoy for many years and put over 175k miles on it. A few months a ago I started to get the cylinder 4 misfire code and I read about every forum on here...
  11. Stalling

    Engine Tunes/Mods
    Have thoroughly cleaned the throttle body and replaced the camshaft sensor, yet it still wants to stall out when braking to a stop or sitting at idle. Also wants to choke off on acceleration. It's not throwing off any code. Need help! This site has been great in the past, hope you can help again!
  12. [SOLVED] Rough idle after spark plug change

    OEM Issues
    Hi everybody! This is my first post, so I hope I threw this in the right place. So I know there are already plenty of threads regarding this sort of thing... I changed my spark plugs, I used AC Delco 41-103 plugs, I made sure they were all gapped around .042, I used dielectric grease, I made...
  13. Idle Problem, Please Help!

    The 02-09 "How-To" and DIY Section
    Hello... I have an 04 GMC Envoy SLT. Its an I6 and just had the transmission rebuilt. It has around 116K miles, and the plugs were changed less than a year ago as well as a professional fuel system cleaning. They cleaned the coil packs but did not change any out. About 6 months ago, well...
  14. Love & Hate Idle/Stall issue

    OEM Issues
    Hey Everyone, I've done quite a bit of research on my idle/stall issue and so I want to see what I might have missed. Other than this frustrating idle issue the trail runs amazing; no loss of power when accelerating or driving with cruise control. I love this SUV; just want it to run right...
  15. Rattling High Idle, and Service Light

    General
    Hidee-Ho neighbors. I just purchased an '04 TB and I have noticed that at a certain rpm, I will have a rattling near the windshield down in the dash. I have come up with some theories, but to no avail. I have made sure everything is tightened down in the engine compartment, so I think there is...
  16. Idle problem 02 Envoy 4.2 4x4

    OEM Issues
    My Envoy runs rough at idle and it is not consistent. The vehicle has 117k so I read and cleaned the throttle body by removing it and getting both sides. I also disconnected the battery while performing the work. When I come to a stop signal the idle is initially smooth and then moments later...
  17. 05' Trailblazer v6 - Engine idles funny and dies when A/C is turned on?!?!

    OEM Issues
    Hey guys I am new to this very informative site! anyway would like to see if any of you can help with my TB issue! My wife was driving today and she claimed that it started idling funny and then when came to a stop it idled up then died. Well I test drove it and everything was fine with a/c off...
  18. Yet another rough idle question

    OEM Issues
    As the subject says, yet another rough idle question... Vehicle: 05' TB I6 w/102K miles Problem: Intermittent rough idle. RPMs drop from 600 down to 400, then back up. Seems like TB is going to stall, but has to actually do so. Doesn't seem to matter if AC is on or off. CEL is NOT on (and...
  19. [SOLVED] Rough Idle/misfire not showing and codes

    General
    I am having a problem with misfiring that I can not pinpoint. When the vehicle is first started the engine runs fine. However after it warms up a little the engine misfires when I come to a stoplight and it also misfires when I am cruising on the highway at around 2100 rpm. I have a code...
  20. [SOLVED] Rough Idle P0306

    Engine Tunes/Mods
    First I would like to thank everyone that makes this site possible-it is invaluable! I had a code p0306 #6 cylinder misfire at 75k miles, no mods, regular maintenance. It had a rough idle but performed good above idle. I put in new plugs and swapped coil packs but still had a miss at idle with...
Top