Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner

electrical

  1. General
    Strange electrical problem I'm having trouble tracking-down. A week ago I'm in the drive-thru ATM and the Envoy quits running. Won't crank, windows won't go up, and can't get the truck out of park (radio and door locks work, though). Have it towed to a shop and they take the column apart but...
  2. OEM Issues
    2005 Isuzu Ascender 4.2L V-6 I recently started having issues with my truck starting. I have previously had some issues that appear to be electrical so I'm not sure if this is just another symptom of a bigger electrical problem or not. I was leaving work and the truck wouldn't start. When I...
  3. Exterior
    My 2004 Envoy has OPT7 HID headlights in them. I wired the BCM so that during the daytime, the DRLs will not cause them to flicker. Regardless, I shut them off anyway to preserve the life of the bulbs. They have worked great, no harness or relay, and seldom flicker upon startup. HOwever...
  4. General
    I recently purchased a 2002 trailblazer, vortec 4.2L I6 LS 2WD. I have noticed that when you are sitting at a stop, and then quickly switch back to gas and begin to accelerate it seems to lose power for a second and then take off. this was the first issue I found until I was driving in town...
  5. General
    I've got what I suspect is an ice problem, but not certain. Backstory: It's below freezing here (Michigan) and I washed my TB last weekend, interior lights worked fine prior to washing, and I don't remember wether they worked immediately after or not, all I remember is they didn't work when I...
  6. General
    My wife left the radio and DVD player on while waiting for the kids to get out of school yesterday, and killed the battery. A man in line with her jumped the Envoy off and the Envoy started right up. However now the radio, heated seat, AC/Heat, windows and door locks do not work. I checked all...
  7. OEM Issues
    When all else fails, turn to the fine folks of the interwebs for help. I have a 2005 4wd I6 SWB Trailblazer with 140K miles, all mine. No mods, stepper moter replacements have been done. Serviced between 3K and 5K miles its entire life. 3 weeks ago, went to pass a vehicle, all dashboard...
  8. Audio and Electronics
    OK, so I grabbed these lights off ebay http://item.mobileweb.ebay.com/viewitem?itemId=170873105679&cmd=VIDESC&index=18&nav=SEARCH&nid=00874485344 my only issue is I dont know where to run the wires exactly. They didnt come with much instruction. Just need to know which wire is the power wire I...
  9. General
    I had to take a video of this because its unbelievable. Today, I shut my trailblazer off and before I removed the key, it locked me in. (only after unlocking the truck when placed in park) Then the red battery light came on with the key off. I also noticed the gear shift indicator illumined...
  10. OEM Issues
    I discovered mouse damage to electrical wires on my 2002 Envoy's I6 engine. The wires are located at the top rear of the engine block. The wires are behind the air intact and below the windshield. Even though my Envoy continues to run without any observable problems, I would like to repair...
  11. General
    Hello all I'm new to the forum, and doing research for a buddy of mine who has no Internet access. I've searched your forums for the answer, and while I've learned a few things, I've not found anything conclusive. My buddy's front windshield washer will intermittently not pump. He swapped it...
  12. OEM Issues
    Hi everyone, I didn't see a specific thread dedicated to electrical, so I hope I'm posting in the right place. A few nights ago, I was driving home. Had been on the road about 5 minutes. Suddenly, the radio dies, guages on the dash die (Oil Pressure, Fuel, Temp, Voltmeter), Tach and Speedo keep...
  13. General
    I've got a 2005 GMC Envoy XL. It use to be that if it wasn't driven for a week the battery would die. Now the battery dies in less than 24 hours after being driven. It does have an aftermarket head unit as well as an overhead DVD player, both installed by a 3rd party, through the dealer when...
  14. Audio and Electronics
    okay i got a pioneer double din i have in a 06 ls tb i had it installed by a audio company....out of town. so my ride brokedown and i had it checked out at the chevy house and they told me that the radio (red wire) was ran to my fuse block and it shorted out the block....it was connected to...
  15. General
    A couple months ago, my rear hatch wouldn't open. I was about to take it to my friend's body shop, as I was really close, but at the next stop -- it worked. After talking to him about it, he told me that it had to be the locks, as they were electrical, as the linkage was manual. I really...
  16. Introductions
    Hey, this is my first post. Id like to start by saying this is a great website and helps a lot of people avoid getting ripped off while allowing them to educate themselves about their vehicles. Now, the bad news. I have an 02 Bravada with 90,000 miles. My wife drives it and three times now it...
  17. OEM Issues
    '06 TB, dead battery. While jumping it, I accidentally touched the fuse box leads with one of the jumper cables, got a small spark. Got the battery replaced, engine starts fine but NOTHING electrical in the TB works. No radio, no A/C, no seat controls, mirrors, nothing. Fuses aren't blown...
  18. Interior
    The front driver’s seat of our 06 Envoy has stopped working. The memory option doesn't move it, the buttons on the side do not move it and the heated seat option doesn't work on either front seat. If you push the buttons to move the seat or push the memory/exit buttons, the seat sits still but...
  19. General
    This red wire: This has probably been disconnected for 2 months now without a problem until today when the battery ran out of charge. Got it started and took it to autozone and they said the diode was bad on the alternator. Would this be related? Thanks CC
  20. OEM Issues
    This is my first forum post, and I am about as good with computers as I am with this car. Bear with me. The battery was running down over night. Removing the radio fuse (a 15 amp fuse in the rear fuse box) after the car has sat for an hour results in a 3.2 amp drop. This is not the whole...
Top