Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner
crank no start
1-7 of 7 Results
  1. OEM Issues
    I have a 2002 chevy trailblazer 4.2 l I6. I was driving it one day, not barbaric, and it pegged out my temp gauge. I immediately pulled over and let it sit, cranked it later that day let it run for about 15 minutes and then killed it. It's sad for about 2 weeks and when I try to crank it it...
  2. 02-09 General Tech Q&A
    I have a 2002 chevy trailblazer 4.2 l I6. I was driving it one day, not barbaric, and it pegged out my temp gauge. I immediately pulled over and let it sit, cranked it later that day let it run for about 15 minutes and then killed it. It's sad for about 2 weeks and when I try to crank it it...
  3. Introductions
    :thx First of all I want to thank everyone for there posts on the site , Its helped me thus far , I have just purchased my first 2003 Envoy XL SLT When I first bought it off a guy it did start , I went back to take it home & nothing , Winters are hell up here in Northern Ontario Canada they use...
  4. General
    My 02 Chevy trailblazer ls 4.2 I6 started having starting issues 2 weeks ago. i was driving down the road and heard what sounded like something hit the bottom of the vehicle but didn't see anything, but once i got home i could smell a strong gas smell only towards the driver side rear tire. I...
  5. The "How-To" and DIY Section
    My tb has been starting just fine and went to start it this morning, and nothing. It's not making multiple clicking noises, just one single click? Any ideas?
  6. General
    I have a 2002 gmc envoy it doesn't start. It cranks and i have check fuel pressure and it was good. I have check for codes and it doesn't have any but check engine light is on. also when you crank it the lights dim, it drains my battery pretty quick. and ideas guys thanks
  7. OEM Issues
    Drove from TN to IL yesterday, woke up this morning drove and got coffee everything fine. Went out again, started my TB, it started fine ran rough for a few seconds died and I have been trying all day to start no SES light on or anything. I leave in a couple days, please help!!:bonk:
1-7 of 7 Results
Top