Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner

alternator

  1. 05 Trailblazer Low Voltage from the Alternator

    General
    Hello All, I have an 05 Trailblazer I have owned since 2006 and I had to replace the positive cable earlier this week. I took it on a long drive over good and poor dirt roads and decent paved roads with no problems and went home. About an hour later on a drive to the gas station, the...
  2. Dashboard indicators and gauges wrong after battery disconnect

    Audio and Electronics
    Hi, on 2002 Oldsmobile Bravada, whenever the battery is disconnected or the vehicle jump started, the needles on all the gauges and the speedometer would spin all over the place and not return to their original position. I have to disconect the battery again and try couple of times before they...
  3. Charging Issues

    General
    Hi everyone, 04 LT, 170k, 40k on the present battery, when I start the truck it often doesn't charge, battery light is on, sometimes when I start driving it will start charging, other times if I shut the engine off and restart, it will charge normally. Had this problem once or twice a while back...
  4. [SOLVED] 2002-2005 Alternator on a 2006 Trailblazer 4.2 LS

    The "How-To" and DIY Section
    I can't really seem to get a fix on why a 2005 Alternator can't be fit on a 2006 Trailblazer 4.2L LS. Is it the amps? The bracket? The connector? 2006 Trailblazer is out on an Island as the 2007-09 also do not retro. I want to fit one of those HO Alts but most only go to 2005.
  5. Volume randomly lowering

    Audio and Electronics
    A few years ago, I installed a new audio system in my 2003 TB without Bose. I replaced the head unit, front component speakers, and added a subwoofer. The head unit powers the rear stock speakers with about 20Wx2 RMS, I have a 50Wx2 RMS amp powering the front components, and a 350Wx1 RMS amp...
  6. Alternator & Battery Help

    OEM Issues
    I replaced the alternator because it was charging way to high and now my battery keeps dying. I had the battery and alternator test at Advance Auto Part and was told the battery was good just needs to be charged and the new alternator is charging at 15.5v and my battery is still going dead. What...
  7. Sluggish starting

    General
    My TBSS seems like the battery is weak when starting. How do you know when it is the battery and when it is the alternator that needs replacement? THX.
  8. Another charging issue

    OEM Issues
    Hey everybody! I have lurked around quite a bit on this site. There is definitely a wealth of info here. Unfortunately I didn't want to make my first post about an issue of mine, but here it goes. I have been suffering from the battery not charging message and the battery light being on. Here...
  9. Over-charging alternator issue

    OEM Issues
    Hi, I have a 6 cyl 2004 Envoy XL w/ 145k on it. Around 50k, I began to see the voltmeter fluctuating between 12 - 14. I saw the lamps dip, and heard the heat / AC fan slow when it happened. No biggie really. Recently, I have noticed the lamps fluctuate back and forth very quickly (1/8-1/2...
  10. continual Battery Lamp on

    General
    I bought my car since 2 weeks, working excellent except one issue The battery indicator red lamp in the instrument panel always ON When I start the engine, this lamp goes off for 20 sec and return on again The voltage scale of the battery in the instrument panel reads 14.5 I did check on the...
  11. Still have crazy voltmeter readings after new batt. & alternator

    OEM Issues
    :confused: Hello, and some advice, please! I had low dash voltmeter readings 2 weeks ago (9v) on the OEM alternator and a 2 year old Pep Boys battery. I ran right to my mechanic and he tested the system. He replaced the battery and serp belt but said the alternator was OK. The next day, I got...
  12. I6 engine trouble!

    OEM Issues
    ok i have a 2004 trailblazer LT 4x4 4.2L I6, and when its sitting in park it bogs down and acts like its going to die(sometimes does), and while in drive there is a very noticeable vibration throughout the TB. Any ideas on what is causing this?? because i am clueless. Also the battery gauge...
  13. Strange electrical issues

    General
    Hi all. Just purchased a certified 08 Trailblazer LT1. Love it so far, but have been noticing a few issues, and wonder if I could get some advice before making an appointment with the dealer (which is over an hour away). 1) Passenger window is slow to rise, sometimes stops completely. I'm...
  14. 06 I6 4WD Won't Turn over

    General
    I went to start my 06 this morning and it wouldn't turn over. All of the cluster warning lights turn on like normal....when i tried to turn it over the first time it started, all the lights stayed on, then it died. I tried a second time and got next to nothing out of it, and it made a rumbling...
  15. 02 to 06 Alternator Difference?

    Engine Tunes/Mods
    After getting the 02 engine swapped with an 06, Ive been noticing on and off weriod screech noises on the engine. The Serp belt was already replaced just to let you know. My friend thinks its has something to do with the alternator since the serp belt is a little off aligned with the idle...
  16. HELP! Flickering dash and dome lights while decelerating

    OEM Issues
    This has been as problem for a little while now that tonight got much worse. I used to think it was just my eyes playing tricks. I'd get a flicker and then it was gone. Tonight it was just going crazy! While costing or decelerating from a highway speed my dash lights and dome lights flicker...
  17. How To: Replacing an I6 alternator

    The 02-09 "How-To" and DIY Section
    zN1ppCxBvjo Well after receiving numerous pm's regarding alternator replacement, I decided that the next time I did one I would take a vid. That day was yesterday. I swapped out an aftermarket HO alt so that it can be shipped out for repair, and put the stocker back in so there is no down time...
  18. Alternator 250

    Alternator 250

  19. Alternator at 15.10 V normal?

    General
    Having some charging system problems as of late. Trying to zero in on the cause. Leaving the TB sit for more than 4 days in cold days (no start) no crank "tic tic tic" Leaving it sit for 2-3 days slow crank, but will start. Leaving it over night and starting will start but you can tell its a...
Top