Chevy TrailBlazer, TrailBlazer SS and GMC Envoy Forum banner
2005 chevy trailblazer

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-7 of 7 Results
  1. 4x4 Drivetrain
    Seems to be a good place for this Q - 2005 TB with fault to replace front actuator. C0739 and service 4x4 light on. Replaced actuator and have same issue after clearing codes. Dash switch blinks for a little bit when attempting to switch to a 4x4 mode, then switches back to 2High on its own. I...
  2. General
    Hello. I posted this earlier but my content shows that I haven't posted anything. So... here goes again. I have a 2005 trailblazer that has started overheating. From day one, there has been no visible water leakage. No water under the car. Also, there is no water in the oil or visa versa. There...
  3. OEM Issues
    Hi, My TB is a 2005 with 4.2l engine with 80k miles on it and has a very bad mpg about 10 mpg. I noticed the following: 1. The previous owner removed the cat and replaced it with a muffler since it was clogged and he also replaced the engine 2. i smell something (fuel or Bad smell) on vehicle...
  4. OEM Issues
    All, I have a 2005 trailblazer (4.2 V6) for which I have changed the water pump 2 times since owning it. As the pump begins to go bad the idle in the car gets rougher and rougher. When I replace the pump it cures the problem until the bearings start to go. I have been replacing it with a $30...
  5. General
    ok I had the following codes, P0106, P0301, P0128, and P0014, I am just shy of 200k miles. We changed the spark plugs out yesterday and disconnected the battery, now when I turn on the recirculation the engine shutters and then dies when I get to a stop or idle point. First question is why it...
  6. General
    Hello all... New guy here with what I'm hoping are not major 2005 Trailblazer (4WD) issues. Background on problems: Approximately 2 weeks ago we had several days of subfreezing temps here in Louisiana. The 2005 Trailblazer had not been run during this period and had sat idle for +/- 10 days...
  7. General
    I'm having a problem with my front AC vents not blowing when I turn the AC on. If I turn the rear AC vents on from the front controls and the rear controls, the vents in the back will blow and blow cool air. I have had a problem before the front vents completely shut off in which the front vents...
1-7 of 7 Results
Top